facetime missing

Discussion in 'Jailbreaks and iOS Hacks' started by brokin, Aug 20, 2010.

  1. brokin macrumors member

    Joined:
    Jun 25, 2010
    #1
    i know there are a lot of posts about this but i cannot seem to get facetime back. i have an iphone 4 with 4.0.0 on it. i jailbreaked my phone after the facetime mms fix was already applied. i havnt tried to use facetime until this morning and i noticed that the icon is missing how the hell do i get it back.

    under settings > phone facetime is turned on. i have tried turning it off and on still no facetime option. i am also connected to exchange and have the camera option enabled so how can i get facetime back? should i just upgrade to 4.0.1 since my SHSH blobs are stored?

    edit: i also installed this "fix" from http://iphonedelivery.advinux.fr/cydia through cydia still no factime.
     
  2. Kayan macrumors 6502

    Joined:
    Jul 7, 2010
    Location:
    CA
    #2
    I would restore. I always try a restore before asking online, you have nothing to lose. Try 4.0.1
     
  3. brokin thread starter macrumors member

    Joined:
    Jun 25, 2010
    #3
    ok ive given up time to upgrade to 4.0.1. good thing my SHSHs are saved :)
     
  4. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #4
    Its not your phone, this was a bug, if you will, with the jailbreak.
    upgrade to .02 then downgrade to .01 and jailbreak, face time will reappear
     
  5. brokin thread starter macrumors member

    Joined:
    Jun 25, 2010
    #5
    ok how can i recover my data from the backup file itunes made im using windows. i really just want my pictures back
     
  6. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #6
    I'm on 4.0 and rely on the unlock. My SHSH haven't been saved yet (still pending) and I tried everything to get FaceTime back. Now I can't restore, nor find a working fix. My APN field is also gone but I could at least create an APN Profile with the "iPhone configuration utility" to use mobile surfing.

    Anything i can try?
     
  7. KGWVU macrumors regular

    KGWVU

    Joined:
    Jun 15, 2010
    #7
    See my post here:

    http://forums.macrumors.com/showthread.php?t=998998
     
  8. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #8
    Thanks, I tried your solution but it didn't work :confused:
    There's something else, if I switch the SIM FaceTime reappears and according to this article I need a carrier update over the air (7.x). While with the replacement SIM (another carrier) I get the required Carrier 7.x, with mine there's "Carrier Unavailable". Yet It has already been working with my SIM.
    I really don't know what else I could try...
     
  9. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
  10. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #10
    German SIM : Simyo
    Working SIM: SFR (French)

    But as I said, the Simyo SIM worked fine 2 days ago. After that I installed quite alot from cydia. Don't know if this has any relevance, since other SIMs do work with FaceTime.

    *edit*
    I just put the Simyo SIM (with a MicroSim adapter) into an iPhone 3Gs and "Cellular Data Network" was there as well as "Carrier 7.0" showing in Settings -> About.

    Now I'm even more puzzled...
     
  11. detronic macrumors member

    Joined:
    Jul 16, 2010
    #11
    I had the same problem with my I4, the facetime was gone, all I did went into my setting(on my Iphone 4), general, reset all settings, and clicked on it, it reset, I still have all my apps and all my data and it came back, no restore no headache, give it a try
     
  12. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #12
    I wanted to avoid this because I have lots of individual settings. Does this option only resets of the native iphone applications or of all? Will the organization in folders be gone too? I tried resetting network settings but that didn't help.
     
  13. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #13
    I just called to replace my microSIM with a new one. Maybe there's some kind of incompability with the iPhone 4.
     
  14. Numl0ck macrumors member

    Joined:
    May 2, 2009
    #14
    Ok, I got it!
    After deinstalling "forwardmsgfix 4.0" and "asCommCenterPatch" APN+FaceTime reappeared in settings -> phone. So far, so good but now I'm facing "call failed" when trying to call an other iPhone4 with FaceTime. Might be my ported number though.

    *edit*
    Success, finally!
    I don't know what the culprit was but that's what I did step by step:

    1) Removing "forwardmsgfix 4.0", "asCommCenterPatch",
    2) Reinstalling "base structure" from Cydia + removing "iPhoneDelivery" from Cydia
    3) Reset "Network Settings"
    4) Reboot

    Now, FaceTime button is visible and FaceTime is working :)
     

Share This Page