Facetime: The server encountered an error..

Discussion in 'Mac Apps and Mac App Store' started by Pokernut, Apr 8, 2011.

  1. Pokernut macrumors member

    Mar 3, 2009
    I'm trying to log into my Facetime but I get the following error "The server encountered an error processing registration. Please try again later."

    Now I've found this advice in on another site:

    " (make sure Facetime is closed)
    1. In Spotlight type in "Keychain Access"
    2. There will be a certificate issued by Apple iPhone Device CA - This certificate was signed by an unknown authority. Delete this certificate (or move it to the desktop, out of the keychain access store)
    3. Launch Facetime and login - this time there will be no error..."

    This seemed to work for everyone else but myself, when I go into keychain access there's no certificate called 'Apple iPhone Device CA'.

    Anyone else run into this problem? Any help would be appreciated.
  2. demonfox13x macrumors newbie

    Oct 13, 2009
    I've got the same problem on Lion GM. FaceTime won't let me log in to my apple id. I've tried multiple logins, deleting preference files and searching for the certificate in Keychain access.
  3. anthorumor macrumors 6502a

    Jun 16, 2009
    Sydney, Australia
    Lots of complaints on the Official Apple forums. Seems like this is a flaw for many people who've done the default AppStore installation process. This has to be fixed!

    edit: i too have this problem. and I too dont have iPhone Device CA.
  4. steeljam505 macrumors newbie

    Jul 24, 2011
    North East Netherlands
    FaceTime® Login Error

    I have the same problem and tried the above with no success
  5. peoplevoice macrumors member

    Aug 19, 2008
    FaceTime not working in Lion

    After moving to Lion I'm getting same error message :
    "The server encountered an error processing registration. Please try again later".
    I've tried all solutions (found in this forum) and nothing has worked yet.
  6. peoplevoice macrumors member

    Aug 19, 2008
    FaceTime now working in Lion

    I'd been trying for several days to fix this problem following many solutions in this forum.

    Finally I got it to work. I just click on the "Time" in the top bar of the computer and choose "Open Date & Time Preferences".

    Then checked "Set date and time automatically" and started to work!!!!!!!
  7. popabczhang macrumors newbie

    Sep 10, 2011
    i succeeded

    I succeeded after "set date and time automatically"
  8. Cammmalot macrumors newbie

    Sep 14, 2011
    This worked for me too! Thank You!
  9. Bigglesworth macrumors newbie

    Jul 16, 2008
    Thanks peoplevoice - that was the solution for me on my Mac for FaceTime and on my iPad and iPhone for iMessage and FaceTime on iOS5!
  10. Sylamy macrumors newbie

    Dec 5, 2011
    Thanks, it worked fine for me too! :)
  11. zoezoezoe macrumors member

    Feb 27, 2008

    you are a genius!!!!!!!!
  12. Frenchdavee macrumors newbie

    Dec 13, 2011
    Just had to register' to thank you for the solution to the Facetime problem-"The server encountered an error processing registration."
    Many thanks to "Popabcghang". From grey-haired newbie!
  13. jacobharvy macrumors newbie

    Jan 24, 2012
    facetime problems...

    this worked for me, i had plugged my friends iphone into my mac today and then my facetime wouldn't work. i looked and found his iphone in keychain deleted it and after facetime worked. i did still have my iphone in keychain it was only my friends that was the problem.
    im not sure but i bet for those with this error that dont have devices still look in key chain for anything with an unknown authority and get rid of it and your problem will be fixed.

  14. metatech macrumors newbie

    Mar 2, 2010
    You can also try the following to delete the expired SSL certicate used by Apple Push Services :
    rm /Library/Preferences/com.apple.applepushserviced.plist

  15. JBasco20 macrumors newbie

    Jul 10, 2012
    i deleted the stuff in keychain and also cleared my hosts file and still getting the same error.... anyone else have any idea's?

Share This Page