Resolved FaceTime will not connect on my network

Discussion in 'Mac Apps and Mac App Store' started by BJB Productions, Mar 31, 2011.

  1. BJB Productions, Mar 31, 2011
    Last edited: Mar 31, 2011

    BJB Productions macrumors 65816

    BJB Productions

    Nov 10, 2008
    Trying to get my iPad and computer Facetime to work on my network. Basically, I know it works because it works outside my network on other networks, but here, it does not work. When I call my friend, he will get the call, and clicks answer, but when after clicking answer, it just gets stuck on "Connecting." When he tires calling me, I don't even get the call.

    What i've tried:
    Opened all the ports Apple recommends opening.
    Reset iPad network settings
    Turned off all security settings on router

    What else can I try? This is so silly.
  2. BJB Productions thread starter macrumors 65816

    BJB Productions

    Nov 10, 2008
    SOLVED! After hours of research, I came across this tiny tiny forum with a bunch of folks who figured it out.

    On the iPad (or iPhone) go to Settings<Wi-fi<slect the blue arrow next to your connected network>then change the DNS to

    It worked! And finally all my push notifications worked too.
  3. macrumors newbie

    Jan 2, 2012
    OMG! It just freaking works.

    Does anyone know why? Not sure yet, but it may make iPhone's FaceTime stop working in the same network. Wicked!


Share This Page