Facing Safari problem

Discussion in 'Mac Basics and Help' started by novetan, Sep 12, 2010.

  1. novetan macrumors 6502

    Sep 3, 2010
    This the 1st time I'm using Safari, a change from Explorer and here's the problem.

    When I click a link from the web page, it didn't open in another window but instead it appears in the same window. There isn't any back button to go back to the original web page. So I have to close and start all over again.

    Is there anywhere I can adjust to have another window open whenever a link is clicked while I still can view the original webpage?

  2. mac2x macrumors 65816

    Sep 19, 2009
    The back and forward buttons should be in your toolbar. If not, select View > Customize Toolbar... and add them. :)

    Attached Files:

  3. novetan thread starter macrumors 6502

    Sep 3, 2010
    Sorry, I should have made more clearer. The "back" tool bar is "blank off". So I'm forced to close the web site and start to search all over again for the original website.
  4. elppa macrumors 68040


    Nov 26, 2003
    Two things:
    [1] Are you sure it's not opening in a new tab instead?
    [2] Can you give us an example — What link, what website?

    This isn't "common" Safari behaviour. If there is history to go back to then the back button will be displayed?
  5. novetan thread starter macrumors 6502

    Sep 3, 2010
    No, I just click the link and I expect another new window will open to show the new website..
    The 2nd post with all the links having same problem.

    Just now I tried on this link and faced the same problem. I'm sure somewhere there must be a box that I need to check or uncheck but I jut can't find it.

    Thanks for any help.
  6. elppa macrumors 68040


    Nov 26, 2003
    Those links will open in a new window/tab. I suspect they are opening a new window (hence no back button) but you can't get back to the original window (not sure why — how familiar are you with OS X generally?).

    From the main menu click:

    [1] Safari > Preferences:

    [2] Now click the “Tabs” icon.

    [3] Now change the first option to look like the screenshot:

    Attached Files:

  7. novetan thread starter macrumors 6502

    Sep 3, 2010
    Thanks for reply. Just switch from PC to Mac and had it for 5 days.

    I done exactly according to your screen shot already before and also playing around with various permutation for the 3 boxes below but this the same (I think nothing got to do with the 3 boxes, right?)

    Is there something still missing.

Share This Page