Factory HDD Not Recognized (New Problem?)

Discussion in 'MacBook Pro' started by Rbastid, Oct 8, 2012.

  1. Rbastid, Oct 8, 2012
    Last edited: Oct 8, 2012

    Rbastid macrumors newbie

    Joined:
    Oct 8, 2012
    #1
    Yesterday I decided to reball my GPU due to graphics problmes (Checker board screen and freeze) its a A1151 so its long off warrenty so figured whats the hell.

    When I started it up yesterday it wouldn't let me use the trackpad or keyboard and then after unplugging it the whole thing wouldn't start up. Found out it was just an unplugged cable.

    After plugging it in I was able to start up fine, loaded with a gray screen, stayed for a bit, then had the Question Mark File Icon, did a little searching and it said thats when it can't find the boot disk. Tried to load in SIngle User and in Safe mode, but when it looks like it'll load it just stayed a gray screen with a pointer (useable with the trackpad)

    So then I went on to booting from the install DVD to check the Disk Utility. CHecked and it only showed the DVD drive and the DVD itself, so I took out the hard drive, checked the connections and reinstalled, the computer restarted itself and booted from the drive, logging me into my desktop with all my files on it. I tried ejecting the DVD but it gave me the spinning rainbow and wouldn't eject, after not being able to get rid of the rainbow it reset, again loading from the DVD and again not seeing my HDD.

    From what happened it would seem the HDD works and all the wires are connected, but it just won't load from it or recognize it. I tried zapping the PRAM and it took some time (unlike when I'd done it before) but did nothing. Also tried the Unplug and hold the power for 5 seconds (forgot what its called) and that also did nothing.

    ANy help to get the HDD working would be a great help.

    Thanks
    -Rich
     
  2. hackerwayne macrumors 6502a

    hackerwayne

    Joined:
    Feb 17, 2012
    Location:
    Kuala Lumpur, Malaysia
    #2
    The HDD is the culprit, (unless you shorted out the HDD logic board connector) try another HDD with fresh OS installed. If the problem still persist then check the HDD cable.
     

Share This Page