Factory unlocked iphone 3gs failed to activate

Discussion in 'Jailbreaks and iOS Hacks' started by TheBold, Nov 2, 2009.

  1. TheBold macrumors member

    Joined:
    Aug 21, 2008
    #1
    I purchased my factory unlocked iphone 3gs 16 GB from apple store in Australia, the installed FW was 3.0.1, first time when I connected it to itunes it was activated. then I upgraded the FW to 3.1.2 ; activated the phone and JB using blackra1n. while I was installing winterboard the phone bricked and failed to start. once I start it, it get to apple logo then switch off. tried to get into DFU but no way to restore. I took the iphone to a service center(not apple) then he said that he will wipe the registery, after wiping the registery he was able to upload the 3.1.2 FW but failed to activate(it says the SIM is not supported) we tried several SIM cards but no lock.
    I restored the phone so many times but again fails to activate.

    1) having said it is factory unlocked, how can I get it activated?
    2) is there any tool to wipe the registry of the iphone..or any similar tool?

    Thanks in advance.
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    DFU Mode ought to get it back to out-of-the-box condition.

    http://www.youtube.com/watch?v=ofpinyGlQ8I

    When it's done, check via "Settings, General, About" that the IMEI and ICCID are still there and correct.
     
  3. TheBold thread starter macrumors member

    Joined:
    Aug 21, 2008
    #3
    Thanks for your proposal...
    what I did was switching off the phone, keep pressing the home button then plug the USB cable, then the phone went to recovery mode...restrored..and JB.

    thanks
     

Share This Page