Factory Unlocked iPhone 3GS Invalid SIm AFTER Reboot - please help

Discussion in 'Jailbreaks and iOS Hacks' started by stuckonreplay, Jun 3, 2012.

  1. stuckonreplay macrumors newbie

    Joined:
    May 16, 2012
    #1
    I bought an officially factory unlocked iPhone off of eBay and YES it was factory unlocked NOT jailbroken so DON'T say it is fake because it came to me on iOS 5.1 and I updated it with iTunes to 5.1.1 and it STILL worked. About a week later I wanted to turn it off for a night. The next morning I turned it on and it said No Service. I then toggled the airplane mode settings and it said Invalid SIM and SIM failure. Can someone please help me? My modem firmware is 05.16.05 and it says Carrier: AT&T 12.0 but I have a T-Mobile SIM in and the iPhone came with an AT&T SIM card I needed to use when I first it to activate it during initial setup.
     
  2. Caspper macrumors newbie

    Joined:
    Jun 5, 2012
    #2
    Hi there

    Who was the seller ?
    I got exactly the same issue today, I was using my Iphone 3gs without any issues, running ios 5.1.1 and suddenly today it stopped working with Invalid SIM error. I already restored several times but had no success.
     
  3. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #3
    You could try a new sim card i had this issues on my iphone 4 last year and after getting a new sim from o2 the issues resolved its self
     
  4. Caspper macrumors newbie

    Joined:
    Jun 5, 2012
    #4
    Yeah, it was the first thing I did.
    Tried two different SIMs and both had the same issue. And SIM's are working properly in different phones, it seems apple canceled the unlock (do not know if that is possible)

    It is a brand new IPhone, so it should not be bad IMEI.
     

Share This Page