Failed hard drive, corruption, and time machine?

Discussion in 'Mac OS X Lion (10.7)' started by J'aime, Apr 18, 2012.

  1. J'aime macrumors member

    Joined:
    Jun 9, 2007
    #1
    I hope this is the right forum, as my issue spans the software/hardware categories.

    Three times over the last three months I've have the "Invalid Node Structure" error (MBP mid-2010). Once disk utility was able to fix it no problem. The last two times, however, (three weeks apart) I had to completely wipe my hard drive and restore from my time machine backup because the INS error seems to have been caused by a deep file system or partition issue--I think ("volume bitmap needs minor repair" was one of the things that came up when trying to repair the INS error)

    I did virus scans with ClamXav to see if I have inadvertently infected my system and it came back clean.

    Getting anxious that my hard drive was failing, I took the computer to be evaluated by certified repair peeps. They replaced the drive and I got my computer back today.

    When I tried to use the set-up assistant to restore my system from my backup, it didn't work. I got to the login screen after waiting two hours for my data to transfer, but it would not recognize my password (I tried several times and I know I was using the right one for the account that I was restoring--and the generic "password" and leaving it blank didn't work either). So I restarted the computer and got stuck on a blue screen upon trying to boot the system.

    I called the repair guy and he recommended I do a hard restart from the blue screen, reboot in repair mode, and reinstall Lion, which I did successfully. He also said that my external drive might be corrupt and that's why the set-up assistant didn't work.

    I desperately needed the data off that drive, however, so when I reinstalled Lion, I used Migration Assistant to move only select files (Documents, Movies, Music, Photos, and Applications) not the whole system. This appears to have worked as I can now access the data that was on the external drive. And, here's the weird part, it created two user accounts on my computer (obviously--the old one from the backup and the new one from setting up Lion clean). When I went to login to the old account my password worked! Why it didn't recognize it when using set up assistant is beyond me . . .

    My questions are:
    Is it possible that, after backing up my hard drive to the external drive, a corruption was transferred to the external drive? And after restoring my system from the external drive during the whole 'invalid node structure" fiasco, I inadvertently copied that corruption to the internal drive again--so I'm caught in this vicious circle of corruption?

    Also, if there is a corruption on my external drive and I copied the data (Documents, movies, music, photos, and applications) onto the new drive in my computer, will the corruption wreak havoc on my new drive? Or might the corruption be contained only to the deeper system files (which I did not restore . . .right? :confused:)? Is there any way to tell other than waiting for an INS or other disk error?

    Sorry if this is confusing. And thanks in advance for any advice and suggestions!
     
  2. robgendreau macrumors 68040

    Joined:
    Jul 13, 2008
    #2
    I'd guess you're right. The system you restored was corrupt and didn't work, so you couldn't access any data, and that eventually led to the inability to even boot. You installed a new system that worked, which in turn allowed you to access the user info that the old system that was previously unavailable to you.

    This brings up a good point about backups: sometimes they mirror problems and restoring just brings the problems back. When I've hosed something I reinstall the system, and then migrate. Perhaps it's not necessary, but it can save going through what you went through.

    Rob
     
  3. spintonik, May 5, 2012
    Last edited: May 5, 2012

    spintonik macrumors newbie

    Joined:
    May 5, 2012
    #3
    Hi,

    I am no means Mac expert, but I know thing or two from computers in general. I really cannot understand, how file corruption could jump from drive to another. You may transfer unreadable files but not the corruption, that would spread further to other files.

    What I believe is the case, is that Time Machine in 10.7 gets messed up if you have different username and/or password in your 10.x backups. 10.7 Time Machine claims that whole external HD is corrupted. However, I used fedora Linux to access the same HD, without (too many) problems.

    With this method, I was able to save my 5000 pictures after my backup external hard drive was "corrupted". 8GB of my documents are still "lost", but I think I should be able to save them too.


    Please allow me to tell my story, I think I am after a Time Machine bug here.

    I have 3 years old iMac, which came with 10.5. I updated it to 10.6 with bought DVD some months ago and felt the system slow, sluggish and problematic, especially in music making usage. Nothing major, just minor glitches.

    So I made sure Time Machine was up to date, + manually copied my pictures and /<Username>/Documents/ -file structure from Mac HD to external HD.

    Then with instructions I found from net, I made a clean install of 10.6, ran all updates, bought 10.7 from Apple store, installed it too and ran all updates. My external HD was connected all the time and Time Machine was making backups from fresh installs - I actually purposefully did try to make sure fresh 10.7 install would have been backupped before I would try to restore my data.

    Unfortunately, this backup did fail, claiming my external HD would be corrupt. In the process, Time Machine in 10.7 confuses itself, and is not able to read the old 10.5 Time Machine data anymore, claiming there are no old backups or that those are unreadable. 10.7 Disk Tool fails 3 seconds after start, claiming my External HD is 100% corrupted and should be formatted.

    Luckily, browsing the same External HD in linux proves 10.7 is wrong. SMAART (HD health status data) says that my HD is pretty ok, just file system is a bit messed up (by 10.7 Time Machine, thank you very much!) Altough Time Machine's access to backup structure is all lost by now (I believe), the files themselves are there, (like a librarian with 300000 books without the list of books and their location) so I believe my files are still there, 8GB of documents hidden inside inifinitely complex date-based file structure with the size of 180GB.

    My conclusion of all this is, that restoring 10.5 Time Machine backup to 10.7 (without 10.6 in between) was a bad idea, there seems to be bugs hiding in Time Machine code.


    I did a mistake of creating a different username, in comparison to original installation. Also, I did not notice it in time, so I did not use "Restore data from different username or computer" -feature. Propably because of this, my /Documents is password protected, encrypted and unaccessable in Linux.

    What I'll do next is to complete clean install all over again, to 10.6 with correct username. Then I'll try to restore my data, before updating to 10.7. Wish me luck! If my luck fails, I can allways revert to using file search function in Linux, in order to locate single files.

    I hope this story helps others to figure out where it went wrong.

    All the best,
    Mikko
     
  4. spintonik macrumors newbie

    Joined:
    May 5, 2012
    #4
    I am more than happy to say, that I am writing this update from functional OS X 10.6 installation :)

    Root structure of the backup HD was gone, but with 10.6 Disk tool, accessed from correct username, I was able to fix it (Unlike with 10.7).

    Also, structure logic of the TimeMachine was gone, files were corrupt and unfixable. But with correct username, I was able to save all my files from manual backup. Whee!

    my Backup HD is now formatted / checked with Disk Tool and full backup was created. I will now make a new manual backup and try to update to 10.7.

    -Mikko
     

Share This Page