Failed hard drive - keep it?

Discussion in 'iMac' started by iOrbit, Apr 28, 2016.

  1. iOrbit macrumors 6502a

    Joined:
    Mar 8, 2012
    #1
    my fusion drive has failed on my iMac 27.

    i didn't encrypt it, and I'm unable to secure erase it.

    im concerned about the data.

    what can i do to keep the hard drive?

    i have Apple Care and intend to get several things replaced in the iMac, but i want to keep the broken drive, or atleast get it securely erased.

    secure erase fails on recovery/disk utility boot up. I haven't tried doing it as an external hard drive via thunderbolt but i expect the result to be the same.

    i just feel frustrated with the options
     
  2. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #2
    I have taken drives apart and taken a drill with a wire brush attachment to the platters...
     
  3. burne macrumors 6502

    burne

    Joined:
    Jul 4, 2007
    Location:
    Haarlem, the Netherlands
    #3
    Take a drill with a 1/4" bit and drill through it. Recovering any data from it will costs tens of thousands of dollars and nobody will invest such amounts of money for *your* data, unless they have reliable proof your data is worth at least ten times as much.

    It's the quickest and cheapest method of making data recovery very expensive.

    Equally cheap but less quick: take it apart, completely. Remove every single screw and nut you can find, until you are left with nothing but lose parts. Rebuilding the drive and recovering the data will again be extremely expensive.
     
  4. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #4
    i can't open the iMac as its under apple care which i need to repair the screen
     
  5. MTI macrumors 65816

    Joined:
    Feb 17, 2009
    Location:
    Scottsdale, AZ
    #5
    How much porn do you have on that drive? :cool:
     
  6. JustMartin macrumors 6502a

    Joined:
    Feb 28, 2012
    Location:
    UK
    #6
    Have you asked Apple what they will do with the hard drive once they've replaced it? Perhaps you can ask them for it back and then you can put it beyond repair in whatever way you think will be most fun (I enjoyed taking a friends to pieces and giving them back to him).
     
  7. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    If its underwarranty, ask that Apple return the hard drive to you.
     
  8. rigormortis, Apr 29, 2016
    Last edited: Apr 29, 2016

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #8
    i found a company that charges $3 to grind up your hard disk , as long as you pay for shipping, they are called cyber crunch recycling. if you want a letter or a video its extra. if you pay for postage just for them to erase and reuse the drive, they will not charge for that.

    i was able to put a 3.5 " drive in a small rate flat rate box to save on shipping


    yeah you will have to read and agree to their terms as part of the repair

    if you absolutely want that hard disk back, then you might have to take it to an authorized apple repair facility , and have it fixed there.

    thunderbolt might actually work as long as the drive has not mechanically failed.

    if you couldn't erase it from a usb key, then using thunderbolt won't work

    thunderbolt would work , if the failed screen is the reason your computer won't start
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    OP:

    Simple question:
    What makes you think the drive has "failed"?

    Just because you can't boot from it, does not mean the drive (actually, there are TWO drives in a fusion drive Mac) has "failed".
     
  10. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #10
    Nope, i googled this first but I'm going to call them next week and ask.

    I'll try it but from what I've googled it doesn't look like they will say yes

    no the screen works but it suffers from this (for over a year but I've been too lazy to just get it fixed since google results have been very discouraging that apple actually consider it an issue.

    [​IMG]

    prior to the failure, the hard drive was being a little noisier than usual. i started to experience some freeze ups to where id have to force shut down a few times before it failed. It also began to beach ball here and there, which it would almost never do.

    then on the last time i force shut down, it would not boot. it would get to the apple logo, and unlike usual - a loading bar would show up it would not load at all and after about 1 minute of sitting there it just turns off by itself.

    I got a thunderbolt cable and hooked it up to my MBP - i was able to access everything but it was EXTREMELY slow. I'm talking about files under 100mb taking minutes to even begin copying over. Anything larger than 50mb was guaranteed to not copy over. Whenever files copied over, it was very slow, slower than usb1 speeds. Again, many files would fail to copy over because they would get the corruption error.

    i can not erase the hard drive with Disk Utility on CMD+R, and neither can i secure erase it. they both fail.

    pretty sure the mechanical drive has failed
     
  11. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #11
    If I'm not mistaken (and I may be) OS X will not allow you to secure erase an SSD. Hard drives and SSDs retain data differently, and your Fusion drive has one of each.

    With a hard drive, a reformat without secure erase essentially only clears the index files so when the OS sees the drive, the index looks empty and it can freely write data anywhere on a drive. On a hard drive, under normal operation, the OS never really normally erases or clears a sector (unless secure erase is done) it just marks one that had data but has since been erased as being available for writing, and the data in the block is still there. When it comes time to write to that block, the HDD just overwrites the used block with new data. That's how file recovery software works, it rebuilds an index from the data leftover on the drive. With secure erase on an HDD, instead of just clearing the index so the drive looks empty, it clears the index and then overwrites all the blocks on the drive, either with random bytes of junk data or blocks filled with binary zeros. I think Disk Utility uses the binary zeros approach for a single pass secure erase, but don't quote me on that. It may switch to a binary pattern during a multiple secure erase pass.

    An SSD is different. When an SSD erases a block it doesn't just mark it as ready for use leaving the data in place like the HDD did, it must first completely erase the data block before it can become available for use again. Since NAND flash blocks in an SSD have a limited number of write/erase cycles before they can't be used anymore, every time one of these blocks is erased and written to, the number of writes available for each block goes down. I suspect this process (secure erase) isn't allowed because each time such an operation is performed it's decrementing the write/erase counts for every NAND block on the SSD and is basically, potentially, shortening the life of the SSD.

    The following tactic may be of use to you (then again, it might not):

    http://osxdaily.com/2013/04/22/secure-erase-mac-ssd-drive-recovery-mode/

    That trick might work with the Fusion drive, but if you notice the date on the article it's a few years old so who knows.

    Another thing you may need to do is first break up the Fusion drive into two non-Fusion components, which needs to be done using the command line version of Disk Utility and then do the secure erase on the drives.

    If you really want to make sure that the Fusion drive itself is bad, you could get Scannerz because it will segregate the SSD and HDD components in the Fusion drive separately and test them by component, letting you know which one is bad. To the best of my knowledge, it's the only tool on the market that can do that. More info on that can be obtained at:

    http://scsc-online.com/Scannerz.html .

    With all that said, because you have Apple Care, you may want to contact them and see if they'll return any bad components for you without necessarily doing all the work I've just outlined. First, you've already paid for it, and second, I see no reason why they would want keep a bad HDD or SSD.
     
  12. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #12
    i appreciate all the information you shared and the helpfulness of your reply. thank you.

    im not sure if i can defuse the drives, are you saying my HDD's might not be failed and that i may still be able to erase them if i diffuse them?
     
  13. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #13
  14. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #14
    i tried it, doesn't seem to work.

    Started Core Storage Operation
    Destroying Logical Volume Group
    Erasing disk1s2
    Input/output error
    newfs_hfs: write( ): Invalid Argument
    Mounting disk
    Could not mount disk1s2 with name (null) after erase
    Error: -69832: File system formatter failed
     
  15. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #15
    There are two possibilities:

    • One of the drives or one of their connections is bad.
    • The OS on the Fusion is new and the OS being used to work on it is older (Mountain Lion and earlier).
    The first one is pretty much self explanatory, and to me it says it's time to let Apple Care earn its keep. The second is tricky, and probably much less likely, but still possible.

    Since Yosemite, the type of file compression being used on the file system is not compatible with OS X versions earlier than Mountain Lion. There's a thread or two on this site somewhere about this topic. Yosemite and El Capitan are backward compatible with the earlier versions of OS X (Mountain Lion and older) but the older OS X versions are not compatible with the file system on the newer OS's. When I found out about this, I booted from a Mountain Lion partition with the Yosemite partition still mounted, and using Terminal.app navigated to the /bin directory on the Yosemite partition. Any time I tried to do an "ls" command or access some of those programs in that directory, it would come back saying "Input/output error." It made me think something was wrong with the disk, so I checked the /var/system/system.log file and instead it was giving a kernel error saying something like "unrecognized file compression" (I don't remember it exactly). This type of compression is present on the system files for sure, but I'm not certain the same is true for user files. Interestingly, a Mavericks based partition could access the Yosemite partition without problem. Whether a Mavericks partition could access an El Capitan partition is something I've never gotten around to trying.

    In any case, if the partition you're booting from is from an earlier OS X version and this type of incompatibility exists, it's possible this may be the problem. It's kind of a long shot, but it might be worth checking.

    Core Storage (Fusion is a Core Storage setup) first became available, primarily for encryption in Lion, but Lion didn't support Fusion technology. Snow Leopard can't make sense out of any Core Storage and sees the drive the same way you might if you put in an unformatted drive.

    Finally, you might want to do a web search on "Error: -69832: File system formatter failed" as some seem to be reporting this may be a Disk Utility bug:

    http://superuser.com/questions/48247/mac-os-x-fails-when-trying-to-format-external-hdd
     
  16. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #16
    What version of the OS are you using? The version of Disk Utility for El Capitan appears to have a number of little bugs in it that present themselves as you've described.
     
  17. Oldmanmac macrumors 6502

    Joined:
    Mar 31, 2012
    #17
    Will a standard home drill be sufficient for this?
     
  18. burne macrumors 6502

    burne

    Joined:
    Jul 4, 2007
    Location:
    Haarlem, the Netherlands
    #18
    Yes. It's aluminium. A decent drill with a 1/4" or 6 mm drill bit will have no trouble with a disk. Take the usual precautions like securely clamping your drive and wearing goggles and hearing protection. ;)
     
  19. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #19
    Make sure the drive is really dead before destroying it.
     

Share This Page