MP 1,1-5,1 Failed High Sierra install - please help

Menthol

macrumors newbie
Original poster
Jul 28, 2013
19
40
I decided today to start the process of upgrading my Mac Pro 5,1 from Sierra to Mojave. Have a SAPPHIRE Pulse Radeon RX 580 waiting to install once I get High Sierra installed.

I never made it.

First I downloaded the update to High Sierra (still with the stock 5870) and got the expected note that I had to update the Firmware. This went fine. I then downloaded the High Sierra update, which began its install normally. But it got stuck at a dark grey screen and I can't unstick it. The apple shows up (with no chime), the progress bar moves along, quickly and then more slowly, then the screen flickers to light gray with no indicator, then to dark grey and nothing seems to be happening. I admit I haven't been all that patient, restarting after a half hour or so but I'm pretty sure nothing is happening.

I can't boot into safe mode or start from recovery mode or start from a cloned backup. I don't think there's a viable working OS on my machine at the moment. There's no chime although I see an apple logo and a progress bar when I start up, but I'm pretty sure this is progress bar for the upgrade installation, not a boot.

Any suggestions welcomed as to how I can get a working OS onto this machine! I reset the SMC and NVRAM but the symptoms are exactly the same.
 
Last edited:

Menthol

macrumors newbie
Original poster
Jul 28, 2013
19
40
UPDATE: It worked! I guess I just needed to be more patient. I'm so embarrassed for crying wolf (but so relieved!)
 

dickiedunn

macrumors newbie
Jun 7, 2019
21
0
I’m about to undertake the exact same update. So how long did it take in the end, and what did you do to get it to work?
 

Menthol

macrumors newbie
Original poster
Jul 28, 2013
19
40
I’m about to undertake the exact same update. So how long did it take in the end, and what did you do to get it to work?
I didn't do anything, to be honest, except eventually be patient. I would say I saw that dark grey screen for more than an hour before it resolved. Some tips and notes:

1) When you do the firmware upgrade, make sure you hold the power button down through the length of the long tone. I initially released when the power lights started flashing and the tone started, but it didn't "take." Did it again and held it down longer, and that worked.

2) Disconnect external drives and as many other cables as you can.

3) Wait, and don't panic like I did.

4) High Sierra will reformat your boot drive to APFS if it's an SSD.

I'm on High Sierra now, just updating this and that. Not moving to Mojave right away. I've had enough adventure today.

Good luck!
 

Ten54

macrumors newbie
Oct 4, 2018
9
1
Perth, Western Australia
I found this conversation quite interesting so I thought I would chuck in my 2 cents
I installed High Sierra the other day from scratch and it took 36 minutes - but then my hard drive is only 500GB!