iPhone Fake firmware version?

Discussion in 'Jailbreaks and iOS Hacks' started by c0venant, Sep 22, 2012.

  1. c0venant macrumors regular

    Jun 26, 2012
    is there an app on Cydia that lets me install apps that require newer iOS versions? I have an iPhone 3G running on iOS 4.2.1 and would like to install Twitter that now requires iOS 5.

  2. Siggen macrumors 6502

    Apr 1, 2011
    Oslo, Norway
    No it's now compiled with the API for iOS5, and thus it cannot run on iOS4.
    With a some very few exceptions this is very true.
  3. c0venant thread starter macrumors regular

    Jun 26, 2012
    what about installing an old version of their twitter app, one that was compatible with iOS 4? are old versions available anywhere?
  4. Redjericho, Sep 22, 2012
    Last edited: Sep 22, 2012

    Redjericho macrumors 6502a

    Sep 16, 2011

    Follow this tutorial, but instead of putting iOS 6, put iOS 5.1.1

    There is obviously a reason you need ios 5, so there may be a few missing/bugged features, or it may not work outright. I can't gurantee this will allow you to download it directly from the app store, but if you can find the .ipa file and install it (this I cannot help you with, as it is against forum rules, the only reason I suggest it is because twitter is free), it will at least allow you to have it on your device.

    You could also just try and find the .ipa file for a previous version of twitter if the above method does not work.

Share This Page