Fallout 3 Boot Camp installation problems.

Discussion in 'Mac and PC Games' started by Esulatell, Jan 8, 2009.

  1. Esulatell macrumors member

    Joined:
    Jan 4, 2009
    #1
    I just bought a boxed version of Fallout 3 for my Alu iMac.
    I tried installing it on Boot Camp (Windows 7 Beta Build 7000) and when I insert the disc it and I run the launcher a window appears that says "Fallout 3 Launcher has stopped working" Then the window saying this closes.
    I can't get past this stage, even when i've been into the disk files and ran setup from there (which worked fine, it installed) but after the installation the same "Fallout 3 Launcher has stopped working" window appears.
    Aswell as the fact that my computer does not say the game has been installed but then I search for Fallout 3 in the Explorer it appears.

    I've tried everything, running compatibility mode, restarting god knows how many times, running as an administrator and patches that won't even install.
    I'm on the edge of insanity :mad:

    Can anybody help?
    Thank you :)
     
  2. Padraic macrumors regular

    Joined:
    Aug 30, 2007
    Location:
    Somewhere between here and there...
    #2
    hmmm... "Windows 7 Beta Build 7000"... Might I suggest installing it on a supported OS (XP or Vista) before you drive yourself insane over something the developers didn't plan for?
     
  3. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
    #4
    He also has a non-mac PC. Bootcamp also installs drivers that of which might not work with Windows 7.
     
  4. Whiternoise macrumors member

    Joined:
    Jun 28, 2008
    #6
    I've got this issue as well, it's odd.. And i'm not running it on boot camp, this is a "proper" install.

    The GECK works fine though.

    And "use XP" isn't really a constructive answer, i've still got XP so that's not a problem for me, i'm just interested as to why it's not working.
     
  5. Esulatell thread starter macrumors member

    Joined:
    Jan 4, 2009
    #7
    So you can use the GECK but you can't play the actual game?
     
  6. Whiternoise macrumors member

    Joined:
    Jun 28, 2008
    #8
    Makes sense really, the GECK only uses the data files and whatever esm/esps you've got, as well as a couple of dlls, it doesn't need the exe.

    However, i got a fix from the bethsoft forums. It appears, surprise surprise, that SecuROM is the cause :D

    OK, Here's what you do!

    Go to the securom website, download the patched fallout launcher. Copy it into your Fallout 3 install directory, back up the old one if you want. Run that and it'll work fine, although mine only seems to work in windowed mode (but it's no less playable!)

    https://support.securom.com/fallout3/index.php?c=fallout3&leng_uk=1
     
  7. r!ggaman macrumors newbie

    r!ggaman

    Joined:
    Jan 31, 2006
    Location:
    Houston
    #9
    To the TS, what version of windows 7 did you download? I just finished installing the 64 bit version and installed fallout 3 with no problems. I had to install a patched version of the apple drivers before I could get windows 7 to run properly.

    Check out this thread and install limo's patch

    http://forums.macrumors.com/showthread.php?t=624375&page=9
     
  8. Esulatell thread starter macrumors member

    Joined:
    Jan 4, 2009
    #10
    I've got Beta Build 7000 and its 32 bit, I think.
    I've downloaded the boot camp patch, now i'm downloading the launcher and securom patches :)
    I should never of sold my xbox :p
     
  9. Esulatell thread starter macrumors member

    Joined:
    Jan 4, 2009
    #11
    Thanks everyone!
    It's working perfectly! :D
    Such a fun game
     
  10. thunderclap macrumors 6502a

    Joined:
    Nov 8, 2003
    Location:
    Chicago
    #12
    I upgraded my 32-bit copy of Vista to Windows 7 over the weekend. I have to say I'm very impressed with it. It loads faster, shuts down faster and even the programs seem to be snappier.

    And like you my copy of Fallout 3 broke. If I tried running FalloutLauncher the game would start with audio but no video. If I tried running Fallout3 it would simply crash. I tried configuring both to run in Vista compatibility mode as well as Windows XP SP2. Nadda.

    I have the nVidia 8800GT graphics card, so I tried upgrading the drivers to the beta provided through Windows Update. That didn't help. Next I ran the SecuROM patch and (today) the new Fallout 3 1.1 patch. Nothing.

    Next I tried your recommendation of patching Boot Camp. I copied the Drivers folder from the Leopard DVD to my desktop, copied the "patched" files into that directory, uninstalled the old Boot Camp files and re-installed this newly patched version. No go.

    Then I started playing with the Fallout 3 configuration. It turns out the game will launch in Windowed Mode but not Full Screen. And, again, only if running the FalloutLauncher app and not Fallout3.

    On a whim I disconnected my 24" Apple Cinema Display and set my 19" Hyundai monitor up as the primary display. Fallout 3 loaded fine!

    So the game doesn't seem to like the Cinema Display. Any guesses why? Everything ran fine under Vista and now Fallout doesn't like the Cinema Display under W7.

    Suggestions?
     
  11. thunderclap macrumors 6502a

    Joined:
    Nov 8, 2003
    Location:
    Chicago
    #13
    UPDATE! In the process of checking the hz settings I discovered W7 had activated my second monitor! (I normally have the smaller one shut off on Windows.) I disabled it and tried the game and it loaded fine in Full Screen! Fallout must have been getting confused with the two monitors set at different resolutions.
     

Share This Page