star-affinity

macrumors 65816
Original poster
Nov 14, 2007
1,460
719
This is on a MacPro5,1 with a Gigabyte RX 5700 XT Gaming OC graphics card.

In Windows 10 the fans stay still if the computer is idle but in MacOS (10.15.4 currently) the fans spins up (not much but noticeably since it kind of kicks in suddenly) every 10 minutes or so and then after a minute they go back to full stop, only to do the same thing again in 10 minutes.

I'm wondering if I'm alone with this behaviour or if it's something that all RX 5700 XT cards supporting passive cooling does in MacOS? Maybe it's just in a MacPro5,1 and not in a eGPU enclosure connected via Thunderbolt 3?

Would be good to know if there's a way around it since it's quite irritating to have the fans spin up like that for (seemingly) no good reason.
 

Matthew92007

macrumors newbie
Jun 17, 2017
8
1
United States, California
I've noticed the same behavior with my Sapphire Pulse RX 590. Even with the computer idling at the desktop in macOS the fans will occasionally spin up.

My guess for the reason is possible background tasks, the idle temperature being above the threshold for the fans to spin, or possibly (but unlikely) the power needed to display to your screen(s) generates enough heat that it needs to be cooled.

Regardless this behavior doesn't seem to happen nearly as often in Windows.
 
  • Like
Reactions: star-affinity

star-affinity

macrumors 65816
Original poster
Nov 14, 2007
1,460
719
@Matthew92007

Thanks for sharing! This didn't happen when I was using a GTX 1070 from Nvidia, but that card also ran cooler and used less power, so… But at the same time interesting that behavior is different in Windows – wonder what would need to change for it to behave similar in MacOS – graphics drivers perhaps.

Also curious if it also happens with the card in a eGPU encluse via Thunderbolt 3 – if that's the case maybe Apple would listen to a report. The probably don't care much about the MacPro5,1 nowadays.
 

Bklyn629

macrumors newbie
Sep 16, 2020
21
0
This is on a MacPro5,1 with a Gigabyte RX 5700 XT Gaming OC graphics card.

In Windows 10 the fans stay still if the computer is idle but in MacOS (10.15.4 currently) the fans spins up (not much but noticeably since it kind of kicks in suddenly) every 10 minutes or so and then after a minute they go back to full stop, only to do the same thing again in 10 minutes.

I'm wondering if I'm alone with this behaviour or if it's something that all RX 5700 XT cards supporting passive cooling does in MacOS? Maybe it's just in a MacPro5,1 and not in a eGPU enclosure connected via Thunderbolt 3?

Would be good to know if there's a way around it since it's quite irritating to have the fans spin up like that for (seemingly) no good reason.

how did you get you 5700 xt to work in Catalina? I still haven’t gotten my red Devil 5709 xt to work. I did tsialex terminal command to install Catalina and thought it was supposed to just work afterwards. Still I get nothing when I swap with my rx 580. Any help will be appreciated
 

AlumaMac

macrumors regular
Jan 25, 2018
192
231
@Matthew92007
Also curious if it also happens with the card in a eGPU encluse via Thunderbolt 3 – if that's the case maybe Apple would listen to a report. The probably don't care much about the MacPro5,1 nowadays.

I have a Razer Core X TB3 eGPU enclosure connected to a Mini and my Sapphire 5700XT fans are running constantly, even when the monitor is asleep (system doesn't sleep). This just started about a week ago without any changes to my system.
 

star-affinity

macrumors 65816
Original poster
Nov 14, 2007
1,460
719
how did you get you 5700 xt to work in Catalina? I still haven’t gotten my red Devil 5709 xt to work. I did tsialex terminal command to install Catalina and thought it was supposed to just work afterwards. Still I get nothing when I swap with my rx 580. Any help will be appreciated

Sorry, I missed your question.
Well, I didn't do anything – the drivers for RX 5700 cards has been there since Catalina 10.15.2 (I think).

I have a Razer Core X TB3 eGPU enclosure connected to a Mini and my Sapphire 5700XT fans are running constantly, even when the monitor is asleep (system doesn't sleep). This just started about a week ago without any changes to my system.

Ouch, that seems bad. :( It's not really happening too often for me that the fans spin up.
 

flowrider

macrumors 604
Nov 23, 2012
6,612
2,558
I am using an Aorus RX5700XT in my 7,1 NcMP and notice no abnormal fan behavior. I have run the card in Catalina and Big Sur. The card is whisper quiet👍

Lou
 

star-affinity

macrumors 65816
Original poster
Nov 14, 2007
1,460
719
I am using an Aorus RX5700XT in my 7,1 NcMP and notice no abnormal fan behavior. I have run the card in Catalina and Big Sur. The card is whisper quiet👍

Lou
No problems with a dark screen followed by a ”watchdog timeout” related Kernel Panic when waking the computer from sleep?

 

Matthew92007

macrumors newbie
Jun 17, 2017
8
1
United States, California
To come back to the original question, I have not noticed the same behavior in Windows 10. Under Windows, the card's fans stay still almost the entire time at idle, whereas in macOS the fans occasionally spin up just sitting on the desktop. I put an acrylic side panel on my Mac Pro, so it's easy to observe the behavior.

My guess is it's just a driver thing, or some task is utilizing the GPU for whatever reason (Photos agent maybe?).
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.