Far Cry 2 + New MBP + XP = "Video card Drivers are too old" ??

Discussion in 'Mac and PC Games' started by ibanana, Oct 27, 2008.

  1. ibanana macrumors 6502

    Joined:
    Aug 23, 2007
    Location:
    London
    #1
    Hi Guys,

    I have a new MBP with Windows XP SP2 and bought Far Cry2 this week end. When the game starts there is a pop-up windows saying "Your video card drivers are too old please change it"

    - What does it mean + how can I update this ?

    I have checked in the nvidia website but can't find anything for the graphic card of the new MBP (NVIDIA 9600M GT)
     
  2. Artofilm macrumors 6502a

    Artofilm

    Joined:
    Oct 12, 2005
    #2
    I get the same thing with my Mac Pro, but whatever, the game still runs great and has no issues.

    Unless the game gives you issues I wouldn't worry about it.
    Apple will probably release a Boot Camp update sooner or later.
     
  3. el.gringo macrumors newbie

    Joined:
    Oct 18, 2008
    #3
    Yeah, I have the same issue, even though I have the latest driver from laptopvideo2go.com Same error message, but the game plays great, so I just ignore it.
     
  4. ibanana thread starter macrumors 6502

    Joined:
    Aug 23, 2007
    Location:
    London
    #4
    thanks guys, actually the game run very smooth.

    By the way what resolution do u have ? I play "High"
     
  5. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #5
    It will still run, but get the Omega Drivers for your machine. They're tweaked and enhanced driver sets to squeeze every bit out of a video card and I pretty much swear by them on my iMac :cool:
     
  6. romo macrumors newbie

    Joined:
    Oct 27, 2008
    #6
    ibanana, what settings are you playing on and what are the specs of your MBP? I'm waiting on my MBP to get here to play Far Cry 2 because it runs like junk on my desktop PC (Radeon HD 3870, 2GB ram, Athlon64 3800). I know my processor is a little dated but Call of Duty 4 runs fantastic on my machine on high settings. I was pretty surprised that FC2 ran so poorly, it is really choppy even on low settings.

    You guys know those Omega drivers are 10 months old right? I'd go with the most up to date drivers from ATI or Nvidia unless there are new Omega's somewhere else.
     

Share This Page