Fast User Switching not working Lion GM

Discussion in 'Mac OS X Lion (10.7)' started by capoeira4u, Jul 3, 2011.

  1. capoeira4u macrumors member

    Joined:
    Feb 9, 2008
    Location:
    Bangkok, Thailand
    #1
    After installing Lion GM, I can't use the fast user switching. Every time I try to activate it (from the menu bar) the screen turns and freezes at a blank gray screen. I do anything except hold the power button and shut down. Anyone having the same problem?
     
  2. deanster2u macrumors newbie

    Joined:
    Jul 19, 2011
    #2
    I have the exact same issue. Anybody have any answers?
     
  3. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_4 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8K2 Safari/6533.18.5)

    Works for my installs.
     
  4. johto macrumors 6502

    johto

    Joined:
    Jan 15, 2008
    Location:
    Finland
    #4
    Mine works just fine. Well, maybe a couple second delay (gray screen) before login screen shows up.
     
  5. wolfpackfan macrumors 68000

    Joined:
    Jun 10, 2007
    Location:
    Cary, NC
    #5
    Interesting. I'm glad I saw this thread. This is the one feature I absolutely have to have working. My wife and I are switching back and forth all day long.

    For those that it was not working for, have you been able to resolve the issue? I had planned on upgrading as soon as it came out, but I'm going to hold off for a little while now.
     
  6. Tutorer macrumors member

    Joined:
    Jun 9, 2011
    #6
    People could post their hardware and if it works or not. It works for me on a 2009 Mac Mini.

    Those having problems could take a look at the Console for error reports. I guess it's a problem with graphics drivers.
     
  7. PeterHolbrook macrumors 6502a

    Joined:
    Sep 23, 2009
    #7
    Works for me.
     
  8. saba01 macrumors member

    Joined:
    Jul 9, 2011
  9. BlaqkAudio macrumors 6502

    Joined:
    Jun 24, 2008
    Location:
    New York
    #9
    MBP in sig. Works for me, but there is a delay (ie. looks like it's frozen on a gray screen, but eventually goes to login screen)
     
  10. merrickdrfc macrumors 6502

    merrickdrfc

    Joined:
    Jan 8, 2011
    Location:
    Berlin
    #10
    It works on my 2010 iMac, but is extremely slow at doing so
     
  11. JangoFett124 macrumors regular

    Joined:
    Jul 16, 2002
  12. Thor0805 macrumors newbie

    Joined:
    Jul 27, 2011
    #12
    Get Gray screen

    Fast User Switching not working Lion..

    13' MBP 2.53 Core 2 Duo
    4GB
     
  13. Spelley macrumors newbie

    Joined:
    Aug 13, 2011
    #13
    I had same problem. Clicked on Fast User Switching icon and nothing happened. I went into SYSTEM PREFERENCES --> USERS & GROUPS --> LOGIN OPTIONS, and changed the "Fast User Switching" option to ICON (which is what I normally use, but oddly, FULL NAME was showing instead... thus the bug?).

    Anyway, this fixed it.
     
  14. jtholb macrumors newbie

    Joined:
    Sep 21, 2011
    #14
    A fix for me

    So, I was having similar issues with fast user switching, as well as being unable to log in to any account from the normal login screen (thankfully I had automatic login for one of the accounts) but found a fix that worked. I also had something weird where one of my administrator accounts couldn't authenticate anything--the password was correct and would be accepted, but then it wouldn't actually give the OS the privileges to actually do anything.

    Anyway, after trying the various listed fixes what worked for me was booting in single user mode (Command-S on boot) and then entering
    Code:
    /sbin/fsck -fy
    at the prompt. On reboot life was back to normal, thank goodness.
     

Share This Page