Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Fast User Switching not working Lion GM

capoeira4u

macrumors member
Original poster
Feb 9, 2008
35
0
Bangkok, Thailand
After installing Lion GM, I can't use the fast user switching. Every time I try to activate it (from the menu bar) the screen turns and freezes at a blank gray screen. I do anything except hold the power button and shut down. Anyone having the same problem?
 

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_4 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8K2 Safari/6533.18.5)

Works for my installs.
 
Comment

johto

macrumors 6502
Jan 15, 2008
381
0
Finland
Mine works just fine. Well, maybe a couple second delay (gray screen) before login screen shows up.
 
Comment

wolfpackfan

macrumors 68000
Jun 10, 2007
1,547
16
Cary, NC
Interesting. I'm glad I saw this thread. This is the one feature I absolutely have to have working. My wife and I are switching back and forth all day long.

For those that it was not working for, have you been able to resolve the issue? I had planned on upgrading as soon as it came out, but I'm going to hold off for a little while now.
 
Comment

Tutorer

macrumors member
Jun 9, 2011
48
0
People could post their hardware and if it works or not. It works for me on a 2009 Mac Mini.

Those having problems could take a look at the Console for error reports. I guess it's a problem with graphics drivers.
 
Comment

PeterHolbrook

macrumors 65816
Sep 23, 2009
1,119
173
After installing Lion GM, I can't use the fast user switching. Every time I try to activate it (from the menu bar) the screen turns and freezes at a blank gray screen. I do anything except hold the power button and shut down. Anyone having the same problem?

Works for me.
 
Comment

BlaqkAudio

macrumors 6502
Jun 24, 2008
488
14
New York
MBP in sig. Works for me, but there is a delay (ie. looks like it's frozen on a gray screen, but eventually goes to login screen)
 
Comment

Thor0805

macrumors newbie
Jul 27, 2011
1
0
Get Gray screen

Fast User Switching not working Lion..

13' MBP 2.53 Core 2 Duo
4GB
 
Comment

Spelley

macrumors newbie
Aug 13, 2011
1
1
I had same problem. Clicked on Fast User Switching icon and nothing happened. I went into SYSTEM PREFERENCES --> USERS & GROUPS --> LOGIN OPTIONS, and changed the "Fast User Switching" option to ICON (which is what I normally use, but oddly, FULL NAME was showing instead... thus the bug?).

Anyway, this fixed it.
 
  • Like
Reactions: erocU2
Comment

jtholb

macrumors newbie
Sep 21, 2011
1
0
A fix for me

So, I was having similar issues with fast user switching, as well as being unable to log in to any account from the normal login screen (thankfully I had automatic login for one of the accounts) but found a fix that worked. I also had something weird where one of my administrator accounts couldn't authenticate anything--the password was correct and would be accepted, but then it wouldn't actually give the OS the privileges to actually do anything.

Anyway, after trying the various listed fixes what worked for me was booting in single user mode (Command-S on boot) and then entering
Code:
/sbin/fsck -fy
at the prompt. On reboot life was back to normal, thank goodness.
 
Comment

erocU2

macrumors newbie
Feb 19, 2019
1
0
I had same problem. Clicked on Fast User Switching icon and nothing happened. I went into SYSTEM PREFERENCES --> USERS & GROUPS --> LOGIN OPTIONS, and changed the "Fast User Switching" option to ICON (which is what I normally use, but oddly, FULL NAME was showing instead... thus the bug?).

Anyway, this fixed it.

There is a good chance this is a 'bug' related to hardware. This solved my issue with High Sierra on a 2011 macBook pro. Switched all accounts to to ICON using instructions from this post and it corrected the issue.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.