Fat32 drive issues after 10.5.6 update

Discussion in 'macOS' started by NoSmokingBandit, Jan 16, 2009.

  1. NoSmokingBandit macrumors 68000

    NoSmokingBandit

    Joined:
    Apr 13, 2008
    #1
    I just installed 10.5.6 (yeah, im a bit behind) and now my fat32 partition wont mount at all. I keep all of my music on that drive in order to share it with my windows partition easily. When i boot into windows everything is fine, i can get to my music and all that jazz, but osx doesnt mount it. So i open Disk Utility and see this:
    [​IMG]
    The important part of that pic is the second drive. That drive has my windows 7 partition, music partition, and a storage partition. Now it seems to think there are 4 partitions. The Disk1s1 is actually named "untitled" and holds windows 7 (i have yet to rename it), but it shows up as disk1s1. The other two (disk1s5 and disk1s6) fail to mount every time. The 1s5 reports ntfs and the 1s6 fat32, though i only have 2ntfs (win7 and storage) and one fat32 (music).
    What the fack is going on here?
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    Almost. You might need to run fsck(aka CHKDSK) on those drives. If you have a Windows computer, the easiest thing to do would be hook it up to that, cleanly disconnect from or shutdown the Windows computer, and then hook back up to your Mac.

    When the drives are not cleanly shutdown, they will often refuse to mount until Windows CHKDSK or scandisk has been run on them. You can also run the OSX/unix equivalent fsck.

    OSX Console app will usually log the reason mount failed, so you might check that as well.
     
  3. NoSmokingBandit thread starter macrumors 68000

    NoSmokingBandit

    Joined:
    Apr 13, 2008
    #3
    I've had some problems with ntfs-3g not mounting correctly so i would reboot into windows, then reboot into Leo and they worked fine. This time i wasnt so lucky though.
    I'll run everything on it i can think of and let you know whats up. Thanks!

    Edit:
    Well, this is peculiar. I ran all the normal disk utils, booted into win7 and ran everything i could through it, rebooted and still had the same error. Rebooted into Leo, reinstalled ntfs-3g, rebooted. Nothing. This sucks. So i reboot to go back to windows and see what i can do but forget to choose the windows partition and end up back in leo by accident, but this time the music partition shows up. *sigh* Computers will kill us all, i swear.
     
  4. NoSmokingBandit thread starter macrumors 68000

    NoSmokingBandit

    Joined:
    Apr 13, 2008
    #4
    :mad:
    I rebooted today and the fat32 drive wont mount again. Same issue as before...
    Any idea whats causing this?
     
  5. NoSmokingBandit thread starter macrumors 68000

    NoSmokingBandit

    Joined:
    Apr 13, 2008
    #5
    Anyone have any other ideas? I asked the forums at apple.com but they are pretty much useless over there :rolleyes:
     
  6. tunerX Suspended

    tunerX

    Joined:
    Nov 5, 2009
    #6
    If you have a windows box you can bring it up and check it then unmount it cleanly.

    You can also run fsck on it through OS X.
     

Share This Page