Fatal error in Aventail VPN client

Discussion in 'Mac Apps and Mac App Store' started by hlkc, Sep 10, 2010.

  1. hlkc macrumors regular

    Joined:
    Jan 15, 2008
    #1
    Not idea why but the my Aventail VPN client worked before is no longer working now - "Unknown FATAL error occurred. Please see logs and contact your Network administrator."

    Rebooted, shut down, deleted using zapit and reinstalled and still show the same error.

    Any help ideas how to solve this one?

    Thanks a million!
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Find the log file and see what it says? Maybe it's located in ~/Library/Logs, where ~ stands for your home folder?
     
  3. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #3
    Were you able to resolve the issue? I had the Aventail Connect client launching and accepting my network credentials but it would never connect. Then after I uninstalled it and re-installed, now it just gives me that Fatal error message on launch.

    The Java console log contained something like:

    [starting up Java Applet Security @ Sat Sep 18 18:46:28 PDT 2010]
    Sat Sep 18 18:46:32 PDT 2010 JEP creating applet com.aventail.xepc.XEPCApplet (https://workplace.xxxx.com/postauthI/)
    <<< ProxyClassLoader: defined LiveConnectProxy class. >>>
    <<< Here're the permissions you've got: >>>
    <<< java.security.Permissions@c7e8a7 ((java.net.SocketPermission workplace.xxxx.com connect,accept,resolve)) >>>
    java.lang.NullPointerException
    at com.aventail.util.AvPluginProxyServiceProvider.getProxyInfo(Unknown Source)
    at com.aventail.xepc.sem.BrowserProxyHandler.detectProxy(Unknown Source)
    at com.aventail.xepc.SEMApplet$2.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.aventail.xepc.SEMApplet.InitializeSEM(Unknown Source)
    at com.aventail.xepc.interrogator.nix.NixEPCInterrogatorImpl.runLogon(Unknown Source)
    at com.aventail.xepc.XEPCApplet$11.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.aventail.xepc.XEPCApplet.RunLogon(Unknown Source)
    at netscape.oji.JNIRunnable.run(Native Method)
    at netscape.oji.LiveConnectProxy.run(LiveConnectProxy.java:48)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at jep.LiveConnect$DoProxy.run(Unknown Source)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

    I have Ubuntu running in VirtualBox and the Linux client works fine. But it would be more convenient to get the Mac client working.
     
  4. lukewarmmizer macrumors newbie

    Joined:
    Oct 12, 2010
    #4
    Aventail Connect "unknown FATAL error"

    I was having the exact same problem, and this is what worked for me:
    1. Uninstall Aventail Connect (entering admin password)
    2. Delete preferences from ~/Library/Application Support/Aventail
    3. Reinstall Aventail Connect from pkg
    4. Check for other TUNs by running "kextstat -l | grep tun"
    5. Remove TUNs found (in this example it is foo.tun) "sudo kextunload -b foo.tun"
    6. Verify that it is removed by running "kextstat -l | grep tun" again
    7. Start VPN, Connect
    8. Profit!

    Hope that helps...
     
  5. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #5
    Thanks Luke. Fortunately my IT department did an upgradecouple weeks ago to 10.5 on the Aventail appliance and the corresponding Connect Tunnel client works on my Mac!
     
  6. jgreene macrumors newbie

    Joined:
    Dec 8, 2010
    #6
    Fatal error in Aventail VPN Client

    I tried the fix and unfortunately no Profit for this cowboy. One question thought. I deleted the initial install with AppZapper, reinstalled and grepped for .tun files and found on so I assumed I was home free but I got the same error message. My one question is whether I needed to be logged in to my machine under the Admin login as I was logged in with my normal users. Could the login ID be in play here? It's a real pain connecting through VMWare. As I want to leverage my backend development tools e.f. Razor for DB Connections for SQL etc versus using clunkster Window tools sets.
     

Share This Page