Faulty Blue Icicle Interfaces

Discussion in 'Digital Audio' started by jacekartymiak, Apr 29, 2009.

  1. jacekartymiak macrumors newbie

    Joined:
    Apr 13, 2009
    #1
    I just seem to have no luck with USB audio interfaces :) First the Tascam US-122L now Blue Icicle. There is a bad batch of Icicles on the market. It seems like the early ones have a problem with voltage adjustment circuitry and add a high-pitched sound to the audio recorded with dynamic microphones. I have no condenser microphone to test my bad Blue Icicle with, but I can confirm that the unit I got does have this problem.

    On the other hand, Blue Icicle does work with all of the audio apps that the Tascam US-122L doesn't. (see my other post)

    I will now try to get a replacement from Blue. Just filled in the Service Request Form.
     
  2. jacekartymiak thread starter macrumors newbie

    Joined:
    Apr 13, 2009
    #2
    Here's a short update. I got quick reply from the Blue Mics people who suggested I should ask the seller to replace the faulty Icicle. Unfortunately, the second unit I got is also broken. There is noise, quieter, but it's there when I record with a dynamic mic. I'm sending the unit back and asking for my money back.

    It wasn't a good introduction to Blue products. I also tried Thomann's t.bone. Stay away from that piece of crap. The mic connector is designed to not connect with the mic(!), it introduces boatloads of noise and can barely amplify a dynamic mic. What a piece of junk!

    I wasn't luck in my search for an affordable USB audio interface... Dang, why is it so hard to find one?
     

Share This Page