Faulty earpiece plz help

Discussion in 'iPhone' started by Tom2kk, Jul 17, 2011.

  1. Tom2kk macrumors newbie

    Joined:
    Jul 17, 2011
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Hey all

    Im getting some trouble when it comes to my iphone 3G earpiece.

    I am trying to make a good phone out of 2 faulty ones,
    No.1- Wifi and earpiece wasn't working,
    No.2- signal and screen wasn't working.

    So I attached the digitiser from no.1 to the screen from no.2 and used the mainboard from no.1.

    Housed in the rest of no.2

    Confusing?

    So now the wifi, signal, and screen are working but the earpiece is still not.

    It rings when a call is made and you can hear if you have it on speaked.

    If anyone has any ideas I would really appreciate it

    Thanks all

    Reply
     
  2. Tom2kk thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Rite so I have swapped the screens back over and I am still getting the same problem.

    Completely puzzled now.
     
  3. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #3
    Time to see an apple genius.

    Make an appointment.
     

Share This Page