Faulty G3 iBook

Discussion in 'PowerPC Macs' started by Adder, Jan 29, 2008.

  1. Adder macrumors newbie

    Jan 29, 2008
    Hello there!

    I have a G3 700mhz iBook which worked perfectly until a few strange things started to happen, they were:

    Track pad would sometimes stop working, but worked fine when I plugged in a mouse.

    Would sometimes refuse to start up when pressing the start up button, it would take between 1-20 presses before it would boot up.

    When it did boot up I would get a message saying the BIOS battery was dead, and I therefore had to set the time etc manually.

    I sent the mac to my local computer repair shop who said the Motherboard was blown. I didn't get them to do any work on it and brought it back home and it started up fine (with not BIOS issues) for a few weeks, then it wouldn't start up at all.

    So my question to you my fellow mac mates, is were all these thing related ie trackpad, bios battery, refusing to start-up and was it the motherboard?

    I would really like to get my iBook going again as I miss it and don't want to throw away a Mac that could be repairable.

    Many, many thanks to whoever responds.

Share This Page