Faulty iMac G3 - PAV?

Discussion in 'PowerPC Macs' started by chrislufc1977, Oct 30, 2013.

  1. chrislufc1977, Oct 30, 2013
    Last edited: Oct 30, 2013

    chrislufc1977 macrumors member

    Joined:
    Feb 10, 2013
    Location:
    Cambridge, United Kingdom
    #1
    Hi all,

    I was given an iMac G3 slot loader today which does not want to turn on.

    I have also been reading a quite bit about the PAV boards. I'm guessing that this is problem with this particular iMac.

    When I plug in the power there does seem to be some hissing/buzzing coming from this.....

    [​IMG]

    Then, when I press the power button there is a white flash in the upper right and lower left of the screen along with the usual sound or the CRT powering up. The screen then stays black. The power button on the keyboard seems to work OK but this has the same effect.

    I was just wondering if there are any other tests that I can do to confirm this as being the PAV board? I have read somewhere about also trying an external monitor.

    I don't want to waste too much time on this iMac but it is in such good condition that it seems a shame not to try.

    Thanks,
    Chris
     
  2. chrislufc1977 thread starter macrumors member

    Joined:
    Feb 10, 2013
    Location:
    Cambridge, United Kingdom
    #2
    There is also no LED coming on on the power bottom and no signs of life from the HDD and DVD drive.
     
  3. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #3
    Capacitors

    Those boards are known due to age for capacitors to go bad. For a few dollars you could get the capacitors and rebuild the board.
     

Share This Page