Faulty USB ports ?

Discussion in 'MacBook Pro' started by mrbroots, Aug 20, 2015.

  1. mrbroots macrumors newbie

    Joined:
    Nov 21, 2014
    #1
    Hi all,

    I think I have a problem with my 2 USB ports. And I'd like you to help me figure this out.

    Yesterday, I tried to restore my sister's iPhone 5c to iOS 8.4.1. I connected the iPhone to my 2014 rMBP, then started the restoration. As it was processing, an error 9 occurred, then the iPhone went to recovery mode because the restoration didn't go thru properly. I tried again, and I got an error 14.

    I looked these errors up at https://support.apple.com/en-us/HT204770, and it reads that it could be a USB problem. I tried another cable, used the other USB port and it still failed.
    Then, I tried restoring on my 2014 iMac. It succeeded at the first attempt.

    I'm now wondering if my rMBP has a USB problem, considering the restoration only failed on this one.
    Could it be something related to the amperage, as if my rMPB was transmitting to much electricity, causing the restoration to fail ?
    Should I clean install Yosemite ? Or should I even hand it over at an Apple Store ?

    Thanks in advance.
    Lyle.
     
  2. ajcgn macrumors regular

    ajcgn

    Joined:
    Oct 19, 2014
    Location:
    Toronto, Ontario
    #2

Share This Page