FCE & iDVD export problems

Discussion in 'Digital Video' started by df43, Aug 4, 2010.

  1. df43 macrumors newbie

    Joined:
    Aug 4, 2010
    #1
    i've searched the internet the last 2 days and am unable to find the anser to my problems. can anyone help?

    problem 1) I created a video in FCE. 16:9. I want to export so I can upload to a website. When I try every combination of export (quicktime conversion) it comes out as 4:3 when I open it in the quicktime player. In quicktime player I can expand and it scales to 16:9. From what I understand this has to do with the format my camera shot in, not true 16:9? Anyway, I just want to be able to export to 4:3 with letterbox black on top and bottom, or a 16:9 format that looks correct. This seems impossible, unless I do a straight export from FCE but that makes a huge file. Specs listed below.

    problem 2) When I take my exported file from FCE (using export > qt movie) and drop it in to iDVD everything works great. Plays on my mac fine, on my widescreen tv fine, even played on a projector fine, BUT when I put it in a DVD player hooked up to an old 4:3 tv it cut off the sides of the video. I can't seem to find any settings anywhere (iDVD or FCE) for anamorphic. It's hard for me to believe that something so basic would be overlooked. specs below. I downloaded an app called anamorphicizer, but it doesn't work with QT player 10.

    Can someone tell me what in the world I am doing wrong on either of these?

    Your time and responses are much appreciated!

    specs:
    iDVD 7.0.4
    FCE 4.0.1
    QT player 10.0
    Mac Book Pro on 10.6.4
    camera: Sony AVCHD HDR-CX100
     
  2. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #2
    #1: Your FCE project is probably in a 4:3 mode. redo your "easy set up".
    Alternatively when you export, chenge the resolution settings to force the resolution of the video to be a 16:9 ratio... ( assuming SDish resolutions ) 640x360 or 720x406 or 480x270 or something to your liking

    #2: The anamorphic part is decided when you pic your iDVD project, and when you do "easy setup" in the FCE config. I doubt this is it. It's probably that you are past the bounds of the TV Safe/Title Safe area for 4:3. In FCE, got to your canvas window and click on the button at the top next to the "100%" window size ... it looks like an inverted crosshairs. Click and hold and turn on "Image+Wireframe" and "Show Overlays" and "Title Safe".

    The inner rectangle you'll see is the "title safe" area... this is the area never to put text outside of, or it will look like crap ( or get cut off ) on a 4:3 TV. The outer rectangle is only important in that anything outside this area *may* get cut off or not be seen at all depending on the brand of television and how much it reveals of the "overscan".
    This isn't talked about much anymore since 16:9 ( and particularly the digital nature of them ) has taken over.
     
  3. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #3
    thanks for the reply.

    on 1) my easy set up is as follows: Apple Intermediate Codec, AVCHD-Apple Intermediate Codec 1440x1080i50. When I change it to anything else I get a message that says unable to locate external devices Apple Firewire 720x480. On export I have tried several different 16:9 settings (export>qt conversion>options>(compression H.264)>size (tried different NTSC 16:9 or 4:3 formats with and without letterbox applied) is that what you are referring to?

    on 2) I edited my video with title safe showing and all my text is well within this area, but when it plays on a standard 4:3 tv it chops off everything outside of the 4:3 area. When it plays, it's like it is actually centering the video on the 4:3 screen and chopping everything outside of that area, if that makes sense...
     
  4. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #4
    1) Why are you taking this video in at 1440x1080? Your camera supports full 1080i ( 1920x1080 ) doesn't it? My quick googling said it did. You need to investigate that.. .you should be importing it at it native resolution

    As for the forced output resolution size, I meant
    Export->Using Quicktime conversion ->options -> SIZE and then force it to be 1920x1080 or whatever size you want that is actually 16:9
    ( remember 1440 x 1080 is not square pixels )

    Your camera *does* seem to offer full 1080i... you can't import using "AVCHD-Apple Intermediate Codec 1920×1080i50" ?

    2) Ah yes I see... that is a strange issue. I wonder if iDVD is getting confused. Lets fix #1 first. Working with this in the right sequcence format is important.
     
  5. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #5
    yes the camera does shoot in 1920x1080, but I was on a mission trip in LA and only had 2 memory sticks, so in order to make them "go further" I was forced to use the second highest recording mode which resulted in the 1440x1080.

    I used the 'force size' and it came out correct! Thanks for that!

    Any idea about the iDVD issue?
     
  6. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #6
    also, by chance, do you know the settings I would want to select for the video to be streamed from a website?
     
  7. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #7
    Excellent! Let try an experiment and use a variation on this for the iDVD problem as well.

    To export the file using Quicktime conversion for iDVD using these settings:

    Do Export->Quicktime Conversion->Options->Video: Apple Intermediate Codec ( framerate "current" , size "other" )
    Options-> Size->Dimensions: PAL 720x576 16:9 ( or NTSC, whichever is right for your region )

    Note, you shouldn't have to do any of this, but I'm trying to work around this weird anamorphic issue.

    Import that into a 16:9 anamorphic iDVD project and see if it fixes the issue.
     
  8. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #8
    That all depends on what your target bandwidth is. If you're wanting to keep it in full 1080i HD ( which I don't recommend ) you're going to need at least 5000Kbps ( H264 )

    There's quite an art to this and several good guides have been presented here and on the web for it. try using MROOGLE or google for it.

    Hope this helps!
     
  9. OrganMusic macrumors 6502

    Joined:
    Sep 21, 2008
    Location:
    Chicago
    #9
    My quicktimes always come out wrong too. I shoot on MiniDV and I think i've got the project settings right, but perhaps not. I've just always fixed it by going in the video properties in quicktime pro and changing it to 853x480.
     
  10. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #10
    so I am about to do this. For my region it is NTSC, so I am going to pick NTSC 720x480 16:9. As I looked at the options though, I am wondering why I shouldn't select HD 1920x... or even HD 1440x... Will choosing the 720x480 cause it not to look as good? Guess I'll find out in about an hour...
     
  11. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #11
    Becuase DVDs can only do SD resolution. You *can* select the higher resolutions, but they'll just get downsized.
     
  12. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #12
    sorry for the delay. I exported the movie per your suggested settings. When I open it in QT 10 on my Mac it is widescreen, looks good. I put in iDVD and made a DVD. Put it in and it squished it together instead of giving me the black bars on top and bottom like i was hoping for. At least its not cutting off anymore, but I was really hoping to get a format that would play on widescreen TV's correctly, and if by chance it was played on a 4:3 set, it would still be widescreen, but with the black bars on top and bottom.

    I also tied to export a self contained movie from FCE hoping that perhaps that might have some different information in the movie file that would help it play correctly on both sets on TV's as the original export from FCE was just a QT movie and I did not check the "self contained" check box. It yielded the same results as the original... chopping off the sides of the movie completely.

    Any other suggestions to get this to play correctly on both types of TV's?

    again, your help is greatly appreciated!
     
  13. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #13
    huntercr,

    is there a way to export a file from FCE and have it be set up so that it is 16:9 but have it actually fit in a 4:3 frame with black bars on the top and bottom? Then I could just have a second movie that could be selected in iDVD for 4:3?
     
  14. OrganMusic macrumors 6502

    Joined:
    Sep 21, 2008
    Location:
    Chicago
    #14
    Easiest way I have found is to get quicktime pro (not quicktime X that comes with SL). Open your movie, select Window | Movie properties. Click video track. Uncheck preserve aspect ratio. Change scaled size from 720x480 to 853x480. Save before closing it and you'll have no more problems. iDVD and Toast will read the size correctly and burn a disc that will play properly on widescreen TVs and with letterbox on SDTVs.

    Another suggestion, when you are having trouble getting the right results out of FCE, you can mark in and out points for a few seconds worth of video on your timeline. Then when you export a quicktime it will only do the part you have marked. Then you can burn a test DVD of that short passage in relatively little time to make sure it comes out right. This will save you a TON of time.
     
  15. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #15
    Well if you go back to FCE and create a new project with easy setup to be 4:3, then you can import your original completed sequence that is 16:9 and it will auto letterbox it for you. ( This way it will be a 4:3 video, but have black bars like you are wanting
     
  16. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #16
    I bought QT 7 pro, and tried this but it didn't work. When I open the video > window > movie properties > video track, the size in 1920 x1080. I still entered 843 x 480 and saved it, but when I burned the DVD with iDVD i ended up with the exact same problem as my original - cutting the the sides completely off. I'm wondering if it might have to do with the theme in iDVD? Any other suggestions? Am I doing something wrong? Thanks so much for your time, and for the additional suggestion.
     
  17. df43 thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #17
    I also tried this, but every "easy setup" that I selected gave me an error about not finding the external firewire device, 480x720, etc, and then gave me option to check again or click ok which seemed to ignore it. I tried several easy setups and imported my video, and it was still widescreen. Also, when I was choosing the "easy setup", I didn't see one that said 4:3, so I selected NTSC. Is that correct? Also for the import I imported my self contained final video, was that what I was supposed to import?
     
  18. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #18
    There should be a checkbox that says "show all" that might give you more options.

    NTSC is correct if you're in North America, PAL is what you should select if you're in Europe

    You want the one that simply says "DV NTSC" or "DV PAL"

    One crucial step is that You need to do "easy set up" first and THEN select a File->new project.

    if you did it correctly, when you import your movie, your Canvas will only likely show one corner of your 1080i video. You'll need to use the grey wireframe to shrink the video
    ( or one quick way to get a grip on it is to double click on the video when its in the canvas and then it will also open in the viewer... switch to the motion tab and dial down the "scale" to 50% or whatever just so you can manipulate the video to where you want.

    Good luck!
     

Share This Page