FCP 10.1.4 and Yosemite 10.10.1 Crashing

Discussion in 'Digital Video' started by NVRENUF!, Dec 5, 2014.

  1. NVRENUF! macrumors regular

    NVRENUF!

    Joined:
    Mar 19, 2012
    Location:
    PERTH, Australia
    #1
    Hi guys

    Like many after installing Yosemite FCP is just always crashing now and giving the spinning wheel of death.

    So sat back and waited. Finally 10.10.1 system update came. No help, finally FCP 10.1.4 was released so i have
    now installed that. And same problem. Program crash's sometimes i can use it for mins, some times crash's right away.

    Very frustrating, has anybody else had this issue any ideas what to do ?

    running on a
    2013 Imac
    24gb ram
    SSD for OSX drive
    and SSD Thunderbolt Scratch disc for FCP
    I7
    GTX680MX Graphic.

    regards

    Tim
     
  2. NVRENUF! thread starter macrumors regular

    NVRENUF!

    Joined:
    Mar 19, 2012
    Location:
    PERTH, Australia
    #3
    Yeah they no help, and my phone support for imac has expired.
    just thought i can't be the only one effected since the upgrade and other people may be having same issues.

    T
     
  3. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #4
    I'm no help but, in general, a clean install of yosemite and then FCP may help. Some system library may have been corrupted along the way. Otherwise make sure your dives are functioning well.
     
  4. NVRENUF! thread starter macrumors regular

    NVRENUF!

    Joined:
    Mar 19, 2012
    Location:
    PERTH, Australia
    #5
    Thanks,

    I will try reinstall FCP first and see if that works trying to avoid redoing entire
    osx.

    With installing fresh FCP, I will need to re import my events ?
    i shouldn't re import my library should i .

    Thanks

    Tim
     

Share This Page