FCP making me render EVERYTHING, wth?

Discussion in 'Digital Video' started by brendanryder, Mar 14, 2009.

  1. brendanryder macrumors 6502a

    brendanryder

    Joined:
    Dec 28, 2006
    Location:
    Calgary
    #1
    ok so im running FCP on my MBP and ive been working on a bunch of clips over the past few day and i have cut down tons of clips and havnt rendered a single thing. But tonight when i open it up it wants to to render everything? it wont even let my put in a cross dissolve, and any clip i bring into the timeline wants to be rendered. why does it keep doing this? i have never had this problem before. i quickly searched it and someone mentioned something about im in the wrong format. But ive been working on it before and had no problems. i cant afford to lose all these cut down clips.

    What am i doing wrong and how can i fix it?

    Thanks
     
  2. chinarider macrumors regular

    Joined:
    Jan 7, 2008
    #2
    I am a FC newbie, but I'll take a stab at it - it sounds like your sequence settings got changed somehow - change them back to the format you are working with and you should be ok.
     
  3. fiercetiger224 macrumors 6502a

    Joined:
    Jan 27, 2004
    #3
    I love posts like these! Everyone is always so vague! :rolleyes:

    But joking aside, what format are you editing in? And what codec was the source footage originally encoded in? These are CRITICAL things that you need to mention in order for us to help you.

    When you're editing, you have to make sure your sequence codec matches the source codec, so that it doesn't have to spend time rendering. And if you're editing in a format that's not recommended for editing, such as h.264, then that'll hamper FCP performance, and also rendering performance. It's always best to edit in FCP recommended formats, such as DV/DVCPRO (for SD content), or ProRes (for HD content).

    Hope this helps!
     
  4. tcgjeukens macrumors regular

    tcgjeukens

    Joined:
    May 16, 2007
    Location:
    IJsselstein, the Netherlands
    #4
    Agree with Fierce Tiger, need more input regarding both your clips settings and sequence settings.

    In general: if source clips and target sequence have the same settings, FCP needs minimal rendering.

    Another item to vary is the RT (Real Time) setting. You will find this button lop left in your timeline window (see picture).

    If you choose Safe RT, FCP wants to display all material without dropping frames. This may require a lot of CPU muscle or Rendering.
    If you choose Unlimited RT, FCP will play as much as possible with available CPU muscle. It may drop frames in display.

    Change these settings and you will see the colour bar about your clips and transitions change.

    Regards,
    Coen
     

    Attached Files:

Share This Page