FCPX 10.0.4 isn't working :(

Discussion in 'Digital Video' started by hitek79, Apr 13, 2012.

  1. hitek79 macrumors member

    Joined:
    Feb 11, 2011
    #1
    I just updated FCPX and now it won't open. First it says I have to update projects, I click OK, and then it crashes. Same thing happens if I hit ignore. I've tried restarting my computer, and that didn't help. Any ideas?
     

    Attached Files:

  2. floh macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #2
    Oh damn, that looks very bad... not much that I can think of... It worked fine for me: Installed 10.0.4, started it and clicked "OK" for the conversion of all projects. It converted and came up within a minute.

    I would try the following: Move your folders
    <home>/Movies/Final Cut Events
    <home>/Movies/Final Cut Projects
    somewhere else or rename them. Final Cut will then hopefully start up, thinking there are no projects to convert yet. Then try to move the folders back (Final Cut might have created new ones that you can overwrite). Maybe the conversion will work if 10.0.4 has started normally once.

    If it doesn't start with the project and events folders moved, I would recommend reinstalling Final Cut from the App Store.

    Of course, before you try any of this, make a backup of the two mentioned Final Cut folders.

    Good luck, and sorry that I can't think of something else or have better news...
     
  3. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #3
    Dont rename the projects/event folders. Just move them away from original spot.
    After that delete FCPX and start from scratch.
    Do you have another system you can test your older projects/events?
    Ive moved 12 projects already with new update and no probs to date.
    Thats across a few Mac Pro's and MacBook Pro's.
    No iMacs to date.
     
  4. floh macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #4
    I haven't tried it, but I tend to believe mBox when he says renaming won't do it. So move them somewhere else and reinstall FCPX.

    I have updated 14 projects so far on a MacBook Pro and an iMac 27", both without problems. So the iMac is not the issue either.

    Good luck!
     
  5. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #5
    The renaming is for peace of mind.
    Moving the folder is to just tackle the problem one thing at a time.
    I forgot to mention that after deleting FCPX from system, find the pref folder and get rid of that too.
    Check this page for any tips:

    http://support.apple.com/kb/TS3893
     
  6. hitek79 thread starter macrumors member

    Joined:
    Feb 11, 2011
    #6
    Blah

    So this is starting to not look very good. I moved everything to a different drive, and reinstalled FCPX and it opened fine. I moved all my events over, worked fine. Moved a couple of projects over, and they worked. Then I moved the current project I'm working on, and it shuts everything down.

    I do have a MBP I can move these projects to, but I can't finish my project on there, it just can't handle it. Any other tips at this point?
     
  7. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #7
    Check this thread at CreativeCow:
    http://forums.creativecow.net/readpost/344/9951

    it could be something in that one project.
     
  8. floh macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #8
    So by now you know that this project (sadly it's the one you are working on) contains the problem.

    I did not find anything in the release notes that I expect could make your project crash, since the most significant changes were new features and hardware support. Nothing of the core seems to have changed a lot.

    You can try to export your project on your MacBook as XML and then import it on your more powerful computer. Obviously you would have to remove the project again first for FCPX to start up at all...

    That is the only easy fix that might work that I can think of right now. If this does not do what you want, you should definitely contact Apple. You can try to post the crashlog (the loooong log that shows up in the Crash Report you made a Screenshot of, it says "Problem Details and System Configuration" on top. I might be able to read something out of this, but no guarantees...
     
  9. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #9
    Check your footages/clips. You can also remove some by dates.
    Sometimes an offending clip can be at a point in time problem.
    Move it out of the Events folder temp.
    Then start it up again.
    Keep trying this till you find the culprit.
    This is common with the other database type NLE called Avid :p
     
  10. hitek79 thread starter macrumors member

    Joined:
    Feb 11, 2011
    #10
    little better news

    Ok, so I went thru the whole project, which is 8 sections, and it's only one section that's about 8 minutes long, so if I have to redo it, it's not the end of the world, but if I can avoid it, I would really like to because it's got a ton of audio and video that's all synced. I've tried renaming everything, but now luck so far. I think I'll check it out on my laptop and see what happens. I haven't updated my laptop yet, so maybe it will still work there.
     
  11. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #11
    That's exactly what David (link) had to do to get back on track. Stuff like this you think you can avoid but it happens.
     

Share This Page