Resolved FCPX 10.1.3 Slow To Open (Load) On cMP

Discussion in 'Digital Video' started by crjackson2134, Oct 19, 2014.

  1. crjackson2134, Oct 19, 2014
    Last edited: Nov 6, 2014

    crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #1
    Here's the problem. When I launch FCPX I get the splash and then it hangs for about 25 seconds with no activity at all. Then it proceeds and works normally. This is with the OS X Yosemite 10.10 (Official Release).

    I had the same problem when working under Mavericks too, but I was able to resolve the issue by following this guide.
    http://osxdaily.com/2013/11/24/slow-...blem-mac-os-x/

    https://discussions.apple.com/thread/5495797?start=30&tstart=0

    Since upgrading to Yosemite the workaround doesn't solve the issue anymore. Does anyone else have this problem and/or a fix?

    EDIT: Fixed

    NOTE: If you have WiFi turned on, you should perform this procedure there too. Man! FCPX opening is instant now!
     
  2. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
  3. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #3
    How many libraries do you have? How many are open once the FCPX does open? How much free space is on your HDDs? (scratch drive if you use one, you should and also your drive where OSX/FCPX is installed.
    Have you tried a simple reboot? When FCPX becomes sluggish a simple restart usually helps me
     
  4. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #4
    At the moment, the problem persists with 1 empty library. Empty or not, the problem remains.

    Application SSD has 300 GB free, 4 TB drive for scratch, rebooted many times, restarted FCPX many times.

    I'm not currently working on any projects, FCPX editing isn't becoming sluggish. The issue is as stated in the title. FCPX stalls for about 30 seconds when launching the app.

    Click App> Instant Splash Screen (Dialogue BoxP)> No activity for at least 30 seconds (like it's searching for a network drive or something)> then program loads quickly.

    It seems normal after that. It just takes forever to launch. I had the same problem in Mavericks but found a fix as linked to in post#1. That fix no longer works after upgrading to Yosemite, so I'm hoping someone can give me a work around for Yosemite.
     
  5. torpidlittle macrumors newbie

    Joined:
    Oct 24, 2014
    #5
    I have the exact same issue that crjackson2134 is talking about !
     
  6. canprince macrumors newbie

    Joined:
    Sep 12, 2013
    #6
    Same issue here as well! On an SSD, FCP used to open in literally, a couple of seconds, regardless of library size. Now, with an empty library, it stalls on the splash screen for at least 25 to 30 seconds before it opens. No issue once it is open. I thought it was my system as I hadn't seen anyone else complain about it. I put Mavericks back on to test and FCP opens really quick.
     
  7. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #7
    Hopefully someone come out with a workaround for this.
     
  8. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #8
    Perhaps its searching through the drives for libraries or video or something and some drives take time to spin up, large drives take longer to search, or perhaps one of the drives or source videos is missing and its trying to find it.

    I dunno, but opening on my rMBP is often slow, but sometimes near immediate especially when I had just quit out of FCP.
     
  9. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #9
    Well, removing all drives except SSD and testing changes nothing. The splash dialogue comes up instantly, then is sits stationary on that screen for about 30 seconds. Then it loads the rest of the way instantly.
     
  10. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #10
    Try closing all the libraries, quit and reopen. It may be looking for video on a drive that no longer exists (waiting awhile for it to spin up).... Dunno, it just seems like when mine sees all the referenced videos it behaves better, but have never tried to isolate, I just go get another cup of coffee :)
     
  11. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #11
    That didn't work. With all libraries closed, the first thing that pops up is a dialogue asking me to select a library. If I hit cancel, closes FCPX. If I select anything, it takes 30 seconds to load.
     
  12. d4rkc4sm macrumors 6502

    d4rkc4sm

    Joined:
    Apr 23, 2011
    #12
    shot in the dark

    open system prefs > startup disk > select your startup disk

    restart

    maybe try reseting PRAM
     
  13. crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #13
    Yeah, done that many times already. At the moment, it's the only startup drive in the system and properly selected. That's not the problem. I can restore to my Mavericks install and it's greased lightning again. Something is awry is Yosemite.
     
  14. torpidlittle macrumors newbie

    Joined:
    Oct 24, 2014
    #14
  15. torpidlittle, Nov 6, 2014
    Last edited: Nov 6, 2014

    torpidlittle macrumors newbie

    Joined:
    Oct 24, 2014
    #15
    I've finally had a chance to try the proposed fix but, unfortunately, it didn't work for me .... :(

    Keep on searching....

    EDIT: I run these two commands in Terminal to force IPv6 to "Off" (Not doable thru the GUI in Yosemite) :

    networksetup -setv6off "ethernet"
    networksetup -setv6off "Wi-Fi"

    And you know what ? It finally fixed the slow start up ! Yeaahhhh!!!!!!
     
  16. crjackson2134, Nov 6, 2014
    Last edited: Nov 6, 2014

    crjackson2134 thread starter macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #16
    Thanks for this. It fixed mine too. I updated post #1 and marked it resolved. Off can't be selected, However, it is doable through GUI by selecting local link only. That's how I fixed mine. Refer to post #1

    Also, if you have both ethernet and wireless active, you should do this for both. It didn't work for me until I also applied this to my wireless connection as well.
     
  17. torpidlittle macrumors newbie

    Joined:
    Oct 24, 2014
    #17
    I'm glad to see that this fix also did the trick for others !!!

    We're happy guys now ;)
     
  18. canprince macrumors newbie

    Joined:
    Sep 12, 2013
    #18
    SUCCESS! Thank you so much for sharing! The configuration change to Link-local only in Network preferences did not work for me. I had to turn it off using the terminal commands. :)

    Regards!
     
  19. cgmaster macrumors newbie

    cgmaster

    Joined:
    Jul 17, 2002
    #19
    OMG, after months of dealing with this, thinking it was failed Audio Unit validations, I did this and it worked! THANK YOU!
     

Share This Page