FCPX and Flash CS6 crash on launch

Discussion in 'OS X Yosemite (10.10)' started by TheralSadurns, Jul 26, 2014.

  1. TheralSadurns macrumors 6502

    Joined:
    Jul 8, 2010
    #1
    Hi there.

    I've installed the public beta of Yosemite but have run into a few issues.
    I am aware of the fact that this is beta software and that as a result not everything will work 100%.

    My main issue, however, is that FCPX and Flash CS6 do not work.
    Flash crashes directly on launch, while FCPX loads the interface... starts beachballing and then crashes.
    From what I have read beforehand I got that CS6 Apps and FCPX should run on DP4/10.10 Public Beta...

    Does anyone have any idea what might be causing this and how to resolve this?

    Oh and... FCPX I already reinstalled. I repaired permissions. I ran safe boot... and tried a few other things...

    I attached the crash reports as .txt files to this thread. Any help would be highly appreciated!
     

    Attached Files:

  2. TheralSadurns thread starter macrumors 6502

    Joined:
    Jul 8, 2010
    #2
    Update 1

    As it turned out... a newly created test user could open FCPX and Flash CS6 without any issues on the same machine.

    Which means Yosemite is just fine... but something is f*ed with my user account.
     
  3. TheralSadurns thread starter macrumors 6502

    Joined:
    Jul 8, 2010
    #3
    Update 2 and solution

    After reading and trying countless things the solution was relatively straight forward:

    ~/Library/ → Get Info... and set Read/Write Privileges for my own account and apply that to ALL ENCLOSED ITEMS, too!

    After that... all peaches again!


    Bonus solution:
    TextWrangler didn't work... trashing the ElgatoTurbo Component fixed it. How it could influence TextWrangler I have no idea... but it worked!
     

    Attached Files:

Share This Page