FCPX crashing when working with audio

Discussion in 'Digital Video' started by ramenaddict, Oct 1, 2013.

  1. ramenaddict macrumors newbie

    Joined:
    May 1, 2013
    #1
    FCPX 10.0.9 / OS10.8.4 / iMac 3.06 i3, 4GB RAM

    While teaching my video editing class today, we started to cover audio within FCPX. All was going well until we started to add Effects, adjusted Pan Mode and Equalizer, and move clips in the Timeline etc.

    FCPX keeps crashing... again... and again.

    From what I found, the "wheel of death" appears when the audio waveforms are generating.

    Is anyone having the same problem? Due to the amount of students I've seen have this problem and its consistency, I'm leaning towards the idea of this being a bug that needs to be fixed.

    Thanks!
     
  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    You are Teaching a class with only 4GB of RAM? You can get into endless pinwheels. Get at least 8GB. Each time you double the RAM in the computer you will notice in improvement.

    THis would be a great lesson for your students. Start with 4GB then upgrade to 16GB is see the difference.

    You could do the same with a hard drive and SSD.


     
  3. MacBookProzak macrumors regular

    Joined:
    Nov 16, 2011
    #3
    What ChrisA shared with you is exactly the place to start.... put as much ram as you can in it.
     
  4. ramenaddict thread starter macrumors newbie

    Joined:
    May 1, 2013
    #4
    Thanks for the advice. Definitely was suspecting a RAM issue. You're totally right: 4GB is not enough for video editing.

    Unfortunately we don't have the budget to upgrade the RAM on 120+ machines, so I guess we'll have to deal with it. If I find any other "work arounds" or solutions besides RAM, I'll be sure to let you all know!
     
  5. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #5
    Yes, there is an easy solution. Take your example videos and compress them (using compressor) to standard definition with a low data rate. You can down sample the audio too. This way you work with tiny files only a few megabytes. Then on import to FCPX don't "optimize" or create proxy media, edit the tiny, low rate video.

    The other option is tell the students to "BYOC" Bring Your Own Computer.
     
  6. llirik macrumors member

    llirik

    Joined:
    Jul 24, 2011
    #6
    Not necessarily RAM (though most probably in this case).

    I'm on the 2013 27" iMac, fully specced out (so 32gb ram)... and all was going fine until i started adding audio effects.
     
  7. rei101 macrumors 6502a

    Joined:
    Dec 24, 2011
    #7
    Most of your problem is the version of OS you are using.

    I upgraded to it and my MacBook Pro with 2GB of ram got so slow and I am getting beach balls even when opening text edit. I can run certain applications, even Final Cut Pro 7 but when I open Firefox the computer... it is better to hard reset it.

    FCX is very consuming, try not having any other application open and practice your tutorials in advance.

    Try to to run the tutorial after resetting the computer.
     
  8. N19h7m4r3 macrumors 65816

    N19h7m4r3

    Joined:
    Dec 15, 2012
    #8
    It's just as the others say, get as much ram in there as you can.

    My Mac Pro just has 24GB of ram and working a small 15-20 minute project I can end up using 23.99GB or RAM, and then get swaps afterwards.

    A quick solution would be to upgrade just your machine for now, so as to finish classes and demonstrations without issue.

    Like others have said, try avoiding transcoding your imports into optimised media.
     

Share This Page