Fell asleep, woke up to damage......

Discussion in 'Mac Basics and Help' started by sailormoon, Apr 1, 2017.

  1. sailormoon macrumors newbie

    Joined:
    Apr 1, 2017
    #1
    Greetings,

    I have been researching online all night yesterday to find a solution to my problem.

    I was working on a document while chilling in my living room like a superwoman till 4AM, fell asleep with my laptop on my lap, snapped awake to a very loud sound!!! Yup you guessed it :D
    Laugh all you want.....
    It didn't freak me out, till next morning when I couldn't see my flash drive on the dest top!
    I noticed some minor damage to the flash drive, but its still intact.

    I tried and was able to find it under desk utility. However, all the options available are greyed out under "First Aid".

    Any assistance would be much appreciated! :"(
     

    Attached Files:

  2. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
  3. sailormoon thread starter macrumors newbie

    Joined:
    Apr 1, 2017
    #3
    I hope not, I only have few important documents there. Thanks god its not huge data.
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    Next time, work in a carpeted room! ;)
    Hope it's not a loss. :)
     
  5. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #5
    OP:
    The "Sandisk" drive in your original post is a USB3 flash drive, is this correct?

    Try this:
    1. Power down -- all the way off
    2. Disconnect the USB flash drive
    3. Reboot, get to the finder
    4. Now, plug in the USB flash drive, and...
    5. ...Wait a few minutes.

    Sometimes, the finder will attempt to repair a damaged USB drive (directory), and then remount the drive.

    Try this to see if it works for you.

    If not, there might be other options.
     
  6. sailormoon, Apr 2, 2017
    Last edited: Apr 2, 2017

    sailormoon thread starter macrumors newbie

    Joined:
    Apr 1, 2017
    #6
    I learned my lesson....
    TV + Living Room + Comfy couch + laptop = Disaster!!!
    Thanks GOD I didn't knock off any drink over my laptop while napping lol
    --- Post Merged, Apr 2, 2017 ---
    Hi Fishrrman!

    SanDisk Cruzer Orbit Flash Drive.

    I tried the above steps.
    The moment I plug in my flash drive, I get

    "The disk inserted was not readable by this computer"

    However, the flash drive is detected under Desk Utility and USB-Hub from System report.
    Even Console detected the drive's serial number at least.

    I was by FedEx earlier and I tried to see if a PC will be able to read my drive? Unfortunately, it didn't even pop!
    So I think Mac is detecting the drive but not able to mount it for some reason.

    I also think the USB port might be damaged from the fall? But I was able to charge my iPhone from it?

    hmmmmmmmm
     

    Attached Files:

  7. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #7
    Something else to try.

    Download ProSoft's "DataRescue":
    https://www.prosofteng.com/downloads/
    You should be able to download it and run it "in test mode" for free.

    Is it able to "see" the problem flash drive?
     
  8. sailormoon, Apr 3, 2017
    Last edited: Apr 3, 2017

    sailormoon thread starter macrumors newbie

    Joined:
    Apr 1, 2017
    #8
    YES, I was able to see the flash drive!
    However, running QuickScan and DeepScan results the following.......

    I think the partition map got damaged?

    At this stage, if a data recovery software is unable to recover the files, time to shed some tears?
    I don't want to bother taking it to a specialist, incur diagnostic fees for nothing :'(

    I still have some slight hope tho especially when I can see some capacity via DeskUtility, not 0 storage.
     

    Attached Files:

  9. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #9
    I once had a damaged partition full of mp3 files that just "disappeared" on me.

    Nothing seemed able to fix it, until I did the following:

    1. I RE-INITIALIZED the entire drive (yes, "erased" it!). However, I DID NOT do a "secure erase" -- I did ONLY a quick re-initialization (which replaces the drive directory but doesn't touch the data). A secure erase will make the data UNRECOVERABLE.

    2. Next, I used DataRescue on the drive. DR was able to "look around" the "empty" directory. It went "right to the platters", and scavenged and recovered almost all of the lost files.

    Folder hierarchies and filenames were lost, but I then "dumped" the whole lot of mp3's into a "clean" iTunes directory. iTunes was able [in most cases] to read the metadata, and "resorted" the files into albums, back where they belonged.

    There's no promise that this could work for you.
    But it might if nothing else does.

    TIP:
    DR will let you recover ONE file in "test mode". To recover the rest, you have to pay.

    But...
    If you have only two or three files "that really matter", you might try this:
    1. Run DR, recover the first most important file.
    2. Completely remove all traces of DR from your computer. Use "EasyFind" to locate and remove.
    3. Download DR again. It -may- run "in test mode" one more time, and let you recover a second file.
    4. If this works, repeat one or two more times.
     

Share This Page