Fellow S6/Edge users: My Galaxy S6 Edge is incredibly laggy.

Discussion in 'Alternatives to iOS and iOS Devices' started by sartrekid, Aug 15, 2015.

  1. sartrekid macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #1
    I have purchased a brand new Samsung Galaxy S6 Edge just a few days ago.

    What I noticed instantly, however, was that it lags and quite intensely so, particularly during scrolling pages, be it when browsing pages on the web or when skimming through the Google Play Store. It really stutters every single time and it's beginning to annoy me.

    It's absurd that my old iPhone 4S or the Sony Xperia Z Ultra don't lag at all, the former being an ancient phone and the latter being almost two years old. This leads me to think something isn't quite right with my new Edge...

    I installed the Nova Launcher because that's my favourite launcher and I'm used to it. Could it be that Touchwiz is better optimized and runs more smoothly than third-party launchers? I didn't do the test as I had heard so many less than stellar reports on Touchwiz that installing a launcher was the first thing I did.

    It's only been a few days and I truly love this device already. I definitely do not want to have to return it. I'm hooked on the beautiful AMOLED screen, the aesthetics of the device itself, pretty much everything looks and feels great except for the heavy stuttering and lag.

    Basically, I'm hoping that you can give me some advice and tips on how to optimize the performance of the phone. I want to use it as my daily driver, so please let me know what steps you recommend I take to make optimal use of the hardware and increase the performance. All suggestions are highly welcomed.

    Thanks!
     
  2. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #2
    Yeah mine does same on scrolling only. It's same regardless of Google Play Newsstand, Tapatalk, Stock browser etc.. (i don't use chrome on mine). The weird thing is if you often scroll with the lagginess to the bottom of the page and then go back to the top it will then scroll a bit more smoothly.

    You can try installing Chrome support library for Samsung Devices
    https://play.google.com/store/apps/details?id=com.chrome.deviceextras.samsung&hl=en
     
  3. The Game 161 macrumors G5

    The Game 161

    Joined:
    Dec 15, 2010
    Location:
    UK
    #3
    sadly I have the same issue

    It was fine for the first month but there are times when it does freeze and refuses to respond and when I text it can at times just takes secs to even start typing.

    Maybe its due to the widgets on there but the software is also another reason. It's not as smooth as it should be sadly.

    It's why going forward this will be my back-up device when i get the iphone 6 plus S.
     
  4. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #4
    We all have the edge right ? I wonder if it is an overzealous 'anti touch rejection' for the sides/edges of the screen.

    Does anyone with a standard S6 have this issue ?
     
  5. Michael Goff macrumors G3

    Michael Goff

    Joined:
    Jul 5, 2012
    #5
    Is it on 5.1.1?

    Have you tried a complete reset?
     
  6. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #6
    Thanks. Well, yes, it doesn't stutter during scrolling once I've gone all the way down and up again because the page's content is fully loaded by then. But it should not stutter the first time around.

    This is a bit of a bummer. With those specs, I definitely didn't expect it to perform worse than my really old devices. I hope I can get this to work better than it does now.

    Thanks for the recommendation.

    No, I haven't. I didn't think it was necessary as it's brand new. :/ Should I give it a try?

    Also, yes, it's running 5.1.1.
     
  7. grkm3 macrumors 6502a

    Joined:
    Feb 12, 2013
    #7
    You just set it up? Make sure all your cloud apps are not syncing or backing up stuff.

    I had Verizon cloud uploading everything on my phone and Google drive and photos showing the same thing.
     
  8. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #8
    I have not synched anything. No backups.
    Browsing via Chrome is not too bad. I can live with that. The Google Play Store is practically unusable though. I don't find the insane amount of stuttering to be acceptable. Even scrolling through each page very, very slowly doesn't improve the performance.
     
  9. grkm3 macrumors 6502a

    Joined:
    Feb 12, 2013
    #9
    How is your data connection.if you are on slow data it will lag loading up.
     
  10. vikingjunior macrumors 65816

    vikingjunior

    Joined:
    Aug 17, 2011
    #10
    Welcome to the world of Samsung, just when you think they got rid of the lag once and for all it makes the laggy self back.
     
  11. MRU, Aug 15, 2015
    Last edited: Aug 15, 2015

    MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #11
    No its not that. I have same page open on my X 2014, Nexus 6 & Z3 and they all scroll fine. It's definitely something else.


    A google search shows many other people reporting same with the Edge in the likes of Facebook, Twitter and other apps that have scrolling.

    http://forums.androidcentral.com/sa...-jittery-laggy-scrolling-driving-me-nuts.html
    http://forum.xda-developers.com/galaxy-s6-edge/help/galaxy-s6-edge-scrolling-lag-browser-t3147076

    There's quite a few threads of similar on XDA.


    Hence I wonder if this happens for standard Galaxy S6 owners ? If not - it could indeed be some form of anti-accidental touch implementation (to prevent accidental touches due to the screens curved edges) and hence not affecting anything other than the Edge ?
     
  12. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #12
    No it doesn't need a reset. I have reset mine and it occurred/occurs on my previous and current S6 edge.
     
  13. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #13
    I have a decently fast connection and all my other devices respond fast and load uncached data fairly quickly and without hiccups. Like I mentioned earlier, it's mainly the Play Store that gives me such headaches. Not sure what to do.
     
  14. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #14
    If it's really bad (mine is merely noticeable) you could try going into recovery and wiping the cache partition. That has helped some people on XDA.
     
  15. Michael Goff macrumors G3

    Michael Goff

    Joined:
    Jul 5, 2012
    #15
    It must be an Edge thing, then. I have a normal S6, and it doesn't lag.
     
  16. MRU, Aug 15, 2015
    Last edited: Aug 15, 2015

    MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #16
    Yeah that's why i am thinking it may be some anti-rejection that's being a little too aggressive especially when trying to scroll fast.

    Mine does have little stutter or hiccups when scrolling - but usually resolves itself after scrolling up and down a bit. I wouldn't call it incredibly laggy though.


    Actually another solution @sartrekid as you say its google play store that is irking you more would be to try signing / deleting your google account is settings and then signing back in. It would be quicker to try that than reset the device anyway.
     
  17. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #17
    I've already done that. I even reverted to the older Play Store version. Nothing's changed.
     
  18. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #18
    :( damn .... Maybe try the signing out / deleting your google account and resigning in ?
     
  19. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #19
    Hmm... that's an idea. I'm going to try and see if that helps.
     
  20. v871305 macrumors member

    Joined:
    May 30, 2014
    Location:
    The Last Shangri-La
    #20
    Yeah - it unfortunately seems like something you will need to live with. I've had my S6e for about 2 months and am running Nova as well. The stock browser is fast, but it stutters a lot when scrolling. Chrome is borderline unusable considering its a flagship device.

    I've never had a device redraw/reset itself so many times during the day - its literally at least once an hour - infuriating. I thought safari on the iPhone 6 Plus was bad, this is a whole new level. I don't know how else to explain it other than to say that it just straight freezes at random points (esp when app switching or waking from sleep).

    Otherwise, its a beautiful device - prob the best one out there hardware wise (although the Note 5 does look amazing - I got to play with it at a T-Mo store and I'm very tempted - I think the extra GB of RAM will solve the problems on the S6e) I find that my S6e is constantly at 90% RAM capacity with no apps running - so the Note 5 might just solve all of that (hopefully)
     
  21. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #21
    Well, I've tried what MRU suggested. It didn't improve the performance of the Google Play Store. I went ahead and reverted it back to factory settings. That's not changed anything either, unfortunately. Everything is pretty much snappy, Chrome is OK, not too good, not too bad, just overall okay. All other applications where you need to scroll a lot work flawlessly. It's just the Google Play Store that continues to be barely usable.

    I guess I'll have to live with it.

    Anyhow, thanks to everyone for the suggestions and advice. :)
     
  22. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #22
    Strange. Hopefully a Google Play Services update will fix it for you. Keep us posted :)
     
  23. jamezr macrumors G3

    jamezr

    Joined:
    Aug 7, 2011
    Location:
    US
    #23
    I had the regular S6 and it did not lag. It was the fastest most responsive smartphone I have ever used.
     
  24. sartrekid thread starter macrumors 6502

    Joined:
    Oct 30, 2014
    Location:
    Germany
    #24
    Why do you no longer have it? Which one do you have now?
     
  25. Michael Goff macrumors G3

    Michael Goff

    Joined:
    Jul 5, 2012

Share This Page