Feral Interactive Games and HD 7950 Problems

Discussion in 'Mac Pro' started by minifridge1138, Mar 21, 2018.

  1. minifridge1138 macrumors 65816

    Joined:
    Jun 26, 2010
    #1
    Hello all,

    I recently installed an official Sapphire HD 7950 in my MP4,1 -> 5,1.

    Since upgrading, none of the games from Feral Interactive work (Lego Harry Potter, Lego Star Wars, etc). I launch the app, get the options window (to select display, resolution, etc), but when I click the "Play" button, it just dies.

    Does anyone else that has same or similar hardware have this problem?

    Thanks!
     
  2. Flint Ironstag macrumors 6502a

    Flint Ironstag

    Joined:
    Dec 1, 2013
    Location:
    Houston, TX USA
    #2
    Got power connected properly? Tried any bench like Furmark?
     
  3. minifridge1138, Mar 21, 2018
    Last edited: Mar 21, 2018

    minifridge1138 thread starter macrumors 65816

    Joined:
    Jun 26, 2010
    #3
    I haven’t tried any benchmarks, but the power cables are seated correctly.

    I downloaded Furmark, but it doesn’t seem to do anything when I click “run stress test” or “run benchmark”
    --- Post Merged, Mar 21, 2018 ---
    I did just play Portal and Portal 2, they seemed to work just fine.

    I also ran a LuxMark benchmark and got 10,318 for the LuxBall HDR Result (which is about what is expected based on other benchmarks).
     
  4. minifridge1138 thread starter macrumors 65816

    Joined:
    Jun 26, 2010
    #4
    Just a follow up: I re-installed MacOS and everything is working now.
    Weird...
     

Share This Page