Fetch email not checking every 15 Minutes

Discussion in 'iOS 8' started by Brad02, Nov 4, 2014.

  1. Brad02 macrumors regular

    Joined:
    Apr 8, 2011
    #1
    I'm having a weird issue where my Fetch email is not consistently checking every 15 minutes since upgrading to 8.1. This was setup using the normal Gmail wizard. I have deleted and re-added the account already. I did not have the issues before 8.1.

    Anyone having any similar issues?
     
  2. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #2
    Haven't seen it in Mail, until just a few minutes ago, on my iPad. Phone has been ok.

    Where I see updates not happening consistently is my third-party calendar app.

    Some days, updates in background well, others, seems like many hours before it might update itself. Sent a bug report to the developer, got back a response that on the Apple developer boards, lots of discussion on background update is wonky in iOS 8.

    Developer also said that iOS 8 background updating is a bit adaptive in that it notices how often and when you access an app, and the OS schedules things when it thinks is ideal. Kinda like OS X process scheduling (do as much as possible at same time to ramp up CPU in a more consistent manner: save battery).

    Don't know about that, but sure does look like scheduling algorithms are off. Seeing similar on OS X: Apple's stock launch file for the weekly "periodic" process runs every 3-4 days, even though Apple has specified to run every 7 days.
     
  3. Brad02 thread starter macrumors regular

    Joined:
    Apr 8, 2011
    #3
    Interesting. It seems that it was not just my fetch email after all. I noticed that my Outlook.com email account had a mail in it from 3:30am and it was 7:30pm when it showed up on my phone. Weird thing is that I was in my "All Mail" inbox forcing a refresh all day. Maybe I'll try a restore and see if that does anything.
     
  4. s2mikey macrumors 68020

    s2mikey

    Joined:
    Sep 23, 2013
    Location:
    Upstate, NY
    #4
    I'm starting wonder if mine isn't fetching of time either now. Doesn't seem like I'm getting emails as often as I should be. Not sure though. I'm going to keep a closer eye on this and do some tests to verify.
     
  5. bluechair1984 macrumors regular

    Joined:
    Jul 7, 2010
    #5
    I have an exchange account, that will some time go for hours without getting mail. This hasn't happened in any previous version of iOS.
     
  6. Belmont31R macrumors 6502

    Joined:
    Nov 23, 2012
    #6
    Same thing here with iOS 8.1. 3 Exchange accounts, and sometimes if I don't open the mail app it won't retrieve any new emails for a very long time. I've always had emails show up on my phone very quickly but not anymore. Now the mail.app on Mac is faster which was never the case before.


    I installed 8.1 as a new phone, and have deleted and added all of my mail accounts at least once with no change. Just very slow.
     
  7. Brad02 thread starter macrumors regular

    Joined:
    Apr 8, 2011
    #7
    Another thing I just noticed... My Exchange account (Outlook.com Email) didn't show I had a mail even after forcing it to check until after I force closed the Mail app.

    I also could not delete mail on my Gmail (Non Exchange account) until after I did this as well. It would still show 8 new unread mails on my phone but, nothing in the inbox after I deleted them. When logging into GMAIL on the web I still showed the 8 mails in my inbox. I closed the mail app and then relaunched it then it would delete them from the server.
     
  8. Brad02 thread starter macrumors regular

    Joined:
    Apr 8, 2011
    #8
    I think I've tracked down the culprit. I only have issues when my Outlook.com email account is added. It appears that sometimes it will hang trying to authenticate/check mail and cause all the other fetch/push processes to hang as well.
     
  9. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #9
    Did you add it as exchange or as Outlook.com option? I have that, 2 gmail accts and yahoo and they work fine. I used outlook.com option though not exchange. Never had and an issue with it that way. Used to use exchange for gmail til they stopped supporting it and it would hang at times. Seems Exchange has always been somewhat unreliable on Apple devices.
     
  10. Brad02 thread starter macrumors regular

    Joined:
    Apr 8, 2011
    #10
    I have tried my Outlook.com both ways. Manually using exchange and the Outlook.com option. Both eventually bomb out causing all email to stop coming through every 15 minutes as I have it set. I remove Outlook.com and my other accounts have no issues.
     
  11. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #11
    Maybe try and set the outlook acct to push. My setup is outlook,yahoo and icloud services set for push. The gmails set for fetch/manual. Never an issue getting mail. I have the gmail app installed just for push notification for one of the gmail accts. Basically use the iOS mail app for all but gmail app just for the notification beeps. Maybe Outlook isn't liking the fetch setting. Push seems to work well.
     
  12. Brad02 thread starter macrumors regular

    Joined:
    Apr 8, 2011
    #12
    My Outlook account has always been set to push. Along with my iCloud. Gmail is fetch since they dropped their push email. Still working flawless without outlook.com email added.
     

Share This Page