Fetching behavior

Discussion in 'OS X Yosemite (10.10)' started by verithingeoff, Mar 31, 2015.

  1. verithingeoff macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #1
    When I click on "Open with" it takes an age for the list of programmes to appear. Is there a fix to speed this up, it used to be virtually instantaneous?[​IMG]
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    Create a new user, reboot, login to the new user and see if the issues happens in the new user account.
     
  3. verithingeoff thread starter macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #3
    Did that and the issue disappears. back to my original loggin and the situation is the same as was, slow fetch[​IMG]
    Where now?
     
  4. randomgeeza macrumors 6502

    Joined:
    Aug 12, 2014
    Location:
    United Kingdom
    #4
  5. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #5
    Check your login items in your accounts preferences (the account with the problem), likely you are loading some software causing this. As a different account doesn't have the issue it would indicate it isn't a blanket OS issue.
     
  6. verithingeoff thread starter macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #6
    Did this cure the fetch problem?[​IMG]

    ----------

    Simon, does hiding the programmes in users and groups stop them from loading?[​IMG]
     
  7. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #7
    Hiding an item will not stop it from running, you would delete the item from the list in login items to stop it from running. Hiding is essentially the same when you manually start a program and minimize it into the dock, hence hiding the launched application. Sometimes hiding has no effect depending on what the application does when it starts.

    Anyhow, start by removing all items in the login list, logout, login and see if this fixes the issue. If it does then go about adding back in, one a time, until you find the application which is causing the issue. Be sure to logout and then login when you add another login item.
     
  8. jbarley, Apr 1, 2015
    Last edited: Apr 1, 2015

    jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #8
    Try this to rebuild the Launch Services database.
    open a Terminal window and copy-paste this line into it. (all 1 line)
    ----------------------
    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user ; killall Dock
    -----------------------
    Now log out and back in and check your "Open with" menu.

    Edit. since the latest Yosemite B3 update I'm also seeing a pause and a "Fetching" message that never used to be when using the Open with menu.
     
  9. verithingeoff thread starter macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #9
    Does this mean that there is no point in doing the launch services repair?[​IMG]
     
  10. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #10
    Try it, it only takes a minute and can do no harm.
     
  11. verithingeoff thread starter macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #11
    A slight improvement[​IMG]Thanks for the advicemate.
     
  12. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #12
    Just finished installing the latest Yosemite B3 update, and the slow "Open with" menu problem appears to have disappeared, instant menus now.
     
  13. verithingeoff thread starter macrumors member

    verithingeoff

    Joined:
    Dec 3, 2012
    Location:
    Sunshine Coast Queensland
    #13
    I'm running 10.10.2, what's Yosemite B3?[​IMG]

    Oh yes the fetch is back to it's awful self again:confused:
     
  14. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #14
    Try this:
    • Press the OPTION key while selecting "Go" on menubar.
    • Select "Library" from the Go menu.
    • Drag the Caches folder to the trash and reboot.
    • Open /Applications/Utilities folder, launch DiskUtility application.
    • On the left side window select the name of your hard drive (Macintosh HD?).
    • Press the Repair Permissions button. Let it finish and exit DiskUtility application.

    See if this gets rid of the issue.
     
  15. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #15
    That would be the Beta version of Yosemite 10.10.3
     

    Attached Files:

Share This Page