Few files in iTunes won't accept metadata changes

Discussion in 'Mac Basics and Help' started by akm3, Sep 8, 2010.

  1. akm3 macrumors 68020

    Joined:
    Nov 15, 2007
    #1
    So, I ripped my DVD's of Battlestar Galactica to iTunes. I select them all and get info and change metadata. All of them change except for one file, that refuses to change. in this case, the album artwork won't change from the first frame of the video to the DVD case picture from Amazon.

    I did them all at the same time and all in handbrake, but this one file just won't accept the change. I've checked the file permissions and it seems to be set correctly.

    I have another ripped CD that no matter what I do, none of the songs will accept changes to their metadata.

    Anyone seen this? Solutions? I tried deleting it from itunes and re-adding it but still no joy. At a loss?!
     
  2. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
  3. OutThere macrumors 603

    OutThere

    Joined:
    Dec 19, 2002
    Location:
    NYC
    #3
    Re-rip rather than just delete and re-add? Maybe there's something wrong with the files themselves.
     

Share This Page