Few questions about the 1.7 firmware.

Discussion in 'MacBook Pro' started by chrislaw, Jan 6, 2010.

  1. chrislaw macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio
    #1
    so every time i upgrade my MBP i go and uncheck the 1.7 firmware. should i just delete it? is it never going to work with the after market HDs? Is the 1.8 out and im not getting it b/c i havent dl'd the 1.7?

    also, my brother is going to be buying a new 13" mbp very soon. he wants to get the 500gb scorpio blue just like i did. Is he going to be able to? do the new ones come with 1.7?

    Thanks.
     
  2. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #2
    EFI 1.8 has not been released, and I don't believe Apple ever acknowledged the problem caused by 1.7 and third party drives. It's looking doubtful that Apple will address this since it's been about 7 months since the problem was first reported. Some people theorize that the SATA cable in the mid-2009 MBPs is causing the problem. If it were me, I would wait until Apple releases the next revision of this machine to see if it's any better at handling SATA 2 speeds.
     
  3. miker2209 macrumors regular

    miker2209

    Joined:
    Jan 2, 2010
    #3
    I use the Hitachi drive that came with the MBP 13 and it too has problems. I think the cable is the problem, i saw someone said they replaced it somewhere in another thread and it worked fine afterwards. I still stick with 1.6 and doing fine with it :D
     
  4. chrislaw thread starter macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio
    #4
    ok, can anyone that has bought one recently tell me what version of the firmware the new one comes with?
     
  5. chrislaw thread starter macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio

Share This Page