FF3 being weird with actionscript 2 interactive map?

Discussion in 'Web Design and Development' started by chiefroastbeef, Oct 7, 2009.

  1. chiefroastbeef macrumors 6502a

    Joined:
    May 26, 2008
    Location:
    Dallas, Texas/ Hong Kong
    #1
    Edit: I've since restarted Firefox3 and the problem seems to be gone, very weird!


    Hello guys and girls,

    I've just made my first interactive map via Flash CS4 using the "onRelease" function with actionscript 2. I have successfully gotten it onto the webpage, however in Firefox 3, the action is not what it is supposed to be. When the cursor mouses over the country, nothing happens unless I click it, and then the tint to the country is applied along with the country's name, and I must click again to go to the linked page.

    http://www.wwn-go.com/_projects.html

    I tried the page in Safari 4, internet explorer via Crossover and it is working as it should. The country tints and country name shows up on mouseover, and when clicked it goes to the linked page.

    Is FF3 being a weirdy? Or am I the only one on team suck?

    Thanks in advance!

    Sam
     
  2. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #2
    Working fine on my FF 3.5.3 for Windows and Adobe Flash 10 (happen to be at work, no Mac) - the countries changed tint, country name displayed on mouseover, country tint changed back and country name gone on mouseout, click took me to country info.

    -jim
     
  3. chiefroastbeef thread starter macrumors 6502a

    Joined:
    May 26, 2008
    Location:
    Dallas, Texas/ Hong Kong
    #3
    Thanks Jim, it is working fine now. It was weird that FF3 wasn't displaying it right while safari and internet explorer displayed it the way it should. But it is okay now.

    Thanks again Jim for you input!
     

Share This Page