File associations can't change

Discussion in 'macOS' started by jcgnu, Dec 27, 2008.

  1. jcgnu macrumors regular

    Joined:
    Dec 30, 2006
    #1
    Hello everyone.

    I've been using Mac OS X for quite a while and I've managed to assign my file associations without a problem so far.

    But today I tried to change all JSP files to open with Smultron instead of Dreamweaver and it doesn't let me. What I did was what I always do: Open a JSP file's information window, select the application I want it to open with and click on "Change all". Normally it does change all files. But this time, once I clicked on the OK button on the confirmation window, it automatically went back to Dreamweaver.

    I've tried it several times with no luck. Am I doing something wrong? Because this is what I always do and it normally works.

    Thanks!
     
  2. Krusjer macrumors newbie

    Joined:
    Sep 20, 2006
    #2
    I have the very same problem. I want to open CSS files in Smultron, not ugly-overkill-behemoth Dreamweaver.

    I open File Info and Change File Association, chooce Change All, and BOOM back to Dream*#@!weaver...

    I even tried the advice from this post (of this thread), and changed the CSS entry in the info.plist file under Dreamweavers system Content, trough the Open Hidden Files capacity in TextWrangler (great app), but it didn't work either...

    I deleted the entire "dict" for CSS from the internal plist of Dreamweaver. No luck... Back to DW even without this thing in the list.

    Isn't there a system setting I can change somewhere? How does Adobe hack this?

    ---
    All you ppl wanting to shout "use cmd+I" please refrain from posting!
     
  3. Ashka macrumors 6502a

    Ashka

    Joined:
    Aug 9, 2008
    Location:
    New Zealand
    #3
    Only two things come to mind:
    Is it Locked and Change permissions, both on get info.

    Some of my movie files had to be changed individually which was a pain but got the job done eventually.
    S.
     

Share This Page