File corruption issues with Panther

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by FlyersFan77, Nov 2, 2003.

  1. FlyersFan77 macrumors newbie


    Oct 23, 2003
    Is anyone else experiencing corruption issues with Panther? This has happened both on my iMac and my PowerBook. All of the sudden my apps like Safari start crashing when I try to launch them. I get an error message from iTunes stating that my music library is an invalid library. It happened a few days after I turned FileVault on for both. The only solution is a complete format and reload of Panther. I'm wondering if this has happened to anyone else or if anyone knows what could be causing this.
  2. mxpiazza macrumors 6502a


    Apr 22, 2003
    cleveland, oh
    Re: File corruption issues with Panther

    this happened to me as well. you didn't have to reformat panther, just delete the library file and iTunes creates a new one the next time you start up. i turned file vault off and am not turning it back on again until at least another .1 update
  3. Rower_CPU Moderator emeritus


    Oct 5, 2001
    San Diego, CA
    FileVault has been fine for me since last weekend...
  4. TMJ1974 macrumors member

    Jul 22, 2002
    iTunes wierd thing

    After installing Panther a few days ago, eveything seems to be going fine.....until, I attach my iPod and get a wierd "this song won't be copied, because the original can't be found" message. It only applied to 3 songs out of 1000.

    I was like...what the he11?

    Rebooted the machine and everything works fine now, the songs are "back"

    Hopefully this will be the most serious glitch. I've never had anything wierd like that happen before.

  5. illumin8 macrumors 6502

    Apr 20, 2003
    East Coast, US
    Re: File corruption issues with Panther

    Filevault is kind of flaky right now. I enabled Filevault on my account and then during my login session I created several gigabytes worth of files in my home directory. When I logged out the next time, my computer just sat there with the hard drive chugging and nothing on the screen but my background image. There was no messsage saying anything like "please wait, encrypting files". After waiting about 20 minutes with the hard drive chugging away and nothing happening, I tried to Cmd-Opt-Esc or anything to kill whatever process. The system was totally unresponsive so I had to hold the power button down for 4 seconds.

    After rebooting, the first time I tried to login, Panther said it couldn't find my home directory. It was just gone... Thinking the worst had just happened (I'd lost my whole home directory), I was about ready to pull out the Panther CDs and reinstall but I decided to reboot one more time. On the second reboot, my home directory was back and everything was just fine.

    Needless to say I disabled filevault and I'm not using it again until they can:
    1. Make it faster.
    2. Make it stable so I don't have to worry about losing data.
  6. AmigoMac macrumors 68020


    Aug 5, 2003
    Just some old files...

    Looking for some data in my PB I could note some files dated from 1904...:)
  7. FlyersFan77 thread starter macrumors newbie


    Oct 23, 2003
    Re: Re: File corruption issues with Panther

    I reformatted because it also killed a few of my apps, like Safari. I tried to reinstall it, but it wouldn't let me.

Share This Page