File disappearing/no icon on Fat32 external drive?

Discussion in 'Mac Accessories' started by viborg, Dec 29, 2008.

  1. viborg macrumors newbie

    Joined:
    Feb 21, 2007
    #1
    While using my MacBook to access an external drive which is formatted Fat32, I attempted to slightly alter the name of a file with a particularly long file name. Once I changed the name, the file extension was cropped, and the file became inaccessible. Now I can see that the file is there (with no extension at the end of the name), but if I click on it or highlight it, it just disappears, and when visible, in place of the file icon there is just a dashed line box.

    The file is also visible with Terminal, but if I try to take any action Terminal reports that there is "no such file or directory." I tried DiskUtility, DiskWarrior, and File Buddy but apparently they don't work too well with the Fat32 format. I also tried repairing permissions, restarting the computer, disconnecting and reconnecting the hard drive, and also rebuilding the desktop (?) using alt-command on startup...all to no avail.

    It's clear what happened: I screwed up - I should have reformatted the drive before I put any files on it, right? But now, I just want my file back. I know it's there. I can see it, and I'm afraid to alter the drive in any way until I can access this file. Any suggestions would be much appreciated.
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008

Share This Page