file permissions driving me insane. HELP

Discussion in 'Mac Basics and Help' started by dcorban, Dec 27, 2011.

  1. dcorban macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #1
    I am trying to do something extremely simple, and it just isn't working.

    I have a Mac mini that I am using as a file server. On this mini are two user accounts.

    I created a single folder and shared it. I gave both user accounts read and write access to both the folder, and the sharing preferences for the folder.

    Fine, I can see the folder on the network and copy and read files to the shared folder. Yay.

    One problem. If I am logged in as one user (over the network using "connect as") and copy a file to the folder, the other user can only read it. The other user cannot move or delete it. The same goes for any folders or files created on the mini by one user. The other user can't delete or move it.

    This is driving me crazy, because I use the mini to download files automatically using various software. Any files or folders created by this software only give write access to one user. The other user only gets read only access.

    How do I fix this? I tried setting the root folder to allow "everyone" read/write access. Didn't help. Any new folders or files still only give read only access to everyone. Why in the world are new folders/files not inheriting the permissions of the root folder?
     
  2. t1937r0, Dec 28, 2011
    Last edited: Dec 28, 2011

    t1937r0 macrumors 6502a

    Joined:
    Sep 5, 2006
    #2
    If you are trying to set up a folder where two (or more) users are basically treated as one, you will need to go to a terminal window to do it.

    In the following example, assume the two user names are One and Two, and that the folder that you want to create and set permissions on is located in One's home folder, and is named "Shared". Since the folder is in One's home, you should perform these commands while logged in as One.

    Open a terminal window and type the following commands: (Expand your Macrumor's browser window large enough to eliminate the "helpful" text wrapping... and there should not be any space characters between the quotes)

    cd ~One
    mkdir Shared
    chmod +ai "One:allow:read,write,delete,readattr,writeattr,readextattr,writeextattr,readsecurity,writesecurity,chown,list,search,add_file,add_subdirectory,delete_child,append,execute,file_inherit,directory_inherit" Shared
    chmod +ai "Two:allow:read,write,delete,readattr,writeattr,readextattr,writeextattr,readsecurity,writesecurity,chown,list,search,add_file,add_subdirectory,delete_child,append,execute,file_inherit,directory_inherit" Shared
     

Share This Page