*File sharing connection failed

Discussion in 'Mac Basics and Help' started by amiemac, Mar 18, 2008.

  1. amiemac macrumors newbie

    Joined:
    Mar 18, 2008
    #1
    Hi There,

    I have just purchased a new iMac with Leopard. I already own a MBP with Tiger and I am trying to shares files between the two. The MBP connects to iMac and shows files easy as...however I have enabled sharing on iMac when I choose Network it recognises the MBP but always says connecting and after a few minutes shows connection failed.

    I have read a few probs like this but no-one seems to have answered them, really hoping it wont be the case for me!

    Thanks a million for anyone who has any feedback...Amie :cool:
     
  2. macswitcha2 macrumors 65816

    Joined:
    Oct 18, 2008
    #2
    Yeah, people don't seem to have a clue about file sharing. I am having several issues with connection and there seems to be no solution to the problem.

    I'm starting to get just as frustrated with Macs as I have gotten with Windows.
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    make sure AFP is enabled in File Sharing for both Macs.
     
  4. Treats macrumors newbie

    Joined:
    Jun 28, 2007
    #5
    What worked for me

    This is an old thread, but it's one of the top search results I found.

    I ran into a "Connection Failed" message in Lion when I tried to set up sharing on my local network. I could share the screen, but not files.

    I had removed the public folders from the list of shared folders, so the only folders you could see were for authorized users. It didn't seem to like that, even if you connected with a name and password.

    I added one of the public folders back as a shared folder and set it to read only for everyone. After that I was able to connect, no problem.



    AFP is Apple Filing Protocol aka AppleShare or AppleTalk. It's what you want to use if you're only sharing among macs.
     
  5. scotty321 macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #6
    Thanks for the tip which helped us solve our AFP "connection failed" problem when using Mac OS X Server. In our case, we accidentally set the "Shared Folders" to allow Others "No Access". However, the folders that we DID want to share were WITHIN the "Shared Folders" folder. So as soon as we set the "Shared Folders" back to "Read Only" again for "Others", everything started working again.
     

Share This Page