File sharing issue between my 2 Macs & Raspberry Pi

Discussion in 'OS X Mountain Lion (10.8)' started by BleepToBleep, Jan 13, 2013.

  1. BleepToBleep macrumors member

    Dec 31, 2012
    Hi all,
    I am encountering a strange issue on my new iMac under Mountain Lion regarding file sharing. I have 3 shared folders, with read access set to "everyone" for all of them. But:
    - On my Macbook Pro under Snow Leopard, I see my iMac but I immediately get the "connection failed" message when I click on it. So I can not even see my shared folders.
    - On my iMac, when I try to connect to my Macbook pro, it works without any issue.
    - On my Raspberry Pi, I see my iMac but I can not list the shared folders.
    - On my Raspberry Pi, I see my Macbook Pro and I can access my shared folders without any issue.

    That is already quite weird, because the sharing preferences are the same on my iMac and on my Macbook Pro (both AFP and SMB activated, read access to everyone).

    Now the even weirder part:
    - On my iMac, my Raspberry Pi appears in the Finder. But when I click on it: connection failed. However I am able to ping it, to access it using SSH and sFTP from my iMac.
    - On my Macbook Pro, the Raspberry Pi also appears in the Finder and I can access it without any issue, and without having done any configuration.

    So to sum up, I have 2 issues:
    - My shared folders can not be accessed from other computers (even from other Macs)
    - I can not access my Raspberry Pi shared folders although it works from my other Mac and I did not configure anything to make it work.

    Please tell me you already faced this issue and you found the solution...
  2. BleepToBleep thread starter macrumors member

    Dec 31, 2012
    An update to my previous message after some more investigation.

    1) The connection from my iMac to the raspberry pi in the Finder works fine now, for no particular reason... It just works without any change.

    2) My iMac is still not able to share anything to other Macs (using AFP) or to SMB clients. There is now one exception to this: from my Macbook Pro under Snow Leopard, I am able to connect to my iMac if I use "connect as" and use my administrator account. I see all my folders, not only the shared ones.

    In the terminal, I tried some commands to check the status of the SMB server. Here is the result:

    $ smbutil status localhost
    Operation timed out: unable to get status from localhost using address

    I guess this means that there is no SMB server running at all?? How can I fix that? I did not investigate on the AFP server yet.
  3. BleepToBleep thread starter macrumors member

    Dec 31, 2012
    Just an update to this: I called Apple Support. Levels 1 and 2 could not fix the issue. They told me they were going to check with the engineers and call me back. They did not call me back.
    In definitive I re-installed my whole system without using the migration from other Mac assistant, and now it works perfectly fine.

Share This Page