File sharing NOT WORKING from Mac OS Sierra to El Capitan

Discussion in 'macOS Sierra (10.12)' started by frozen220, Oct 3, 2016.

  1. frozen220 macrumors member

    Joined:
    Jun 29, 2007
    #1
    So in my office my co-worker's machine (iMac w/ Sierra) needs to connect to mine (iMac w/ El Capitan) via the local network.

    We're on the same network. My iMac has file sharing turned on, and on my co-workers Sierra machine, my iMac shows up in the Finder as an available machine to connect to, as it should and is expected.

    HOWEVER... when I click on my iMac from her machine, and then go to "Connect as..." and try to log in (yes, the credentials are listed on my machine so that I can log in), it doesn't let me in. I put in the proper username and password, it "thinks" for a few seconds, then "shakes it's head no" - you know what I mean, access denied.

    I can connect to my iMac from a third co-worker's machine just fine using the EXACT same method, but she is on an even older version of Mac OS (I think Mountain Lion).

    Why is this happening? Soooo frustrating. This is obviously a bug with Sierra.

    And no, I'm not ready to update my machine to Sierra until the kinks are worked out (specifically the Logitech mouse issue).

    I've included a screenshot of my file sharing settings on my iMac that I wish my co-worker to connect to. My login on this machine is "iMac Media 5K" and thats what I want her to use. But, it won't give access with no explanation.

    PLEASE HELP!!!!
     

    Attached Files:

  2. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #2
    Looking like you have the machine name and the user name the same - I'd never do that, you're inviting conflict. (that's actually not allowed with the SMB protocol btw - netbios names must be unique).

    If on the other machine, using finder you use the Go, Connect to server and paste in one of the protocols which should work for anyone (with no credentials), what happens?
    afp://192.168.1.81
    smb://192.168.1.81

    As you've specified full privilege for everyone, that includes guests, so no credentials should be required to connect.
     
  3. frozen220 thread starter macrumors member

    Joined:
    Jun 29, 2007
    #3
    That worked! Very odd that Sierra isn't letting me do it the way I've been doing it for YEARS. Not sure what the difference is but whatever, it's working. Thank you!
     

Share This Page