File Sharing - unable to add users or change permissions

Discussion in 'Mac OS X Server, Xserve, and Networking' started by mrk2010, Dec 27, 2010.

  1. mrk2010 macrumors newbie

    Dec 27, 2010
    Hey everyone, first post here, and also a Mac noob, so I apologize if this is in the wrong section :)

    I am trying to enable file sharing in OS X 10.6 Snow Leopard. I intend to share files on my MacBook with other Windows and Linux computers on my home network. From what I understand, the procedure is as follows:

    1) Open up System Preferences and click on Sharing under Internet & Wireless
    2) Click on File Sharing on the left, and then add a folder to be shared. After doing this, three Users appear on the right: System Administrator, Administrator, and Everyone (all have read/write access).
    3) I want my folder to be password-protected and accessible only to specific users, so I change the permissions for Everyone to No Access. I then add a user (sharing only account) with a specified username and password.
    4) I click on Options and select the "Share files and folders using SMB (Windows)", and enable SMB sharing for the user that I created in the previous step. I click on Done, and exit System Preferences.

    After performing the above steps, I go to my Linux computer and attempt to connect to the shared folder on my Macbook. I was surprised to be able to access the folder without being prompted for a username and password. The same thing can be seen on my Windows computer.

    I went back into Systems Preferences/Sharing on my MacBook, and noticed that the user that I had created has disappeared from the Users list, and all the permissions have been reverted to the default Read & Write Access (including Everyone, which I had changed to No Access earlier). I tried the above procedure again and still ended up with the same result.

    Why are the user permissions not being saved? Has anyone here experienced a similar issue?
  2. Matthew Yohe macrumors 68020

    Oct 12, 2006
    Those settings should certainly stick. Is this running the latest 10.6 release? (10.6.5)

    Maybe reboot and see if anything gets fixed.
  3. mrk2010 thread starter macrumors newbie

    Dec 27, 2010
    Tried rebooting...I still have the same issue.

    I have the latest version of Snow Leopard (10.6.5) and I updated my software today.
  4. mrk2010 thread starter macrumors newbie

    Dec 27, 2010
    I think I've figured out what the issue is, so I'm posting for the benefit of any user who may come across this problem in the future.

    I was sharing a folder on an NTFS partition on my hard drive. The NTFS partition is intended to be used as a shared storage space between my dual-boot OS's of Windows 7 and OS X on my MacBook (since Windows 7 is unable to read from the HFS+ file system that OS X uses).

    When I tried sharing a folder on my Macintosh HD (in the HFS+ file system), I was able to have the settings stick. I'm not sure why it didn't allow the settings for the NTFS volume to stick, especially since I have NTFS-3G installed to enable write access to the volume, as well as read. (By default, OS X doesn't allow write access to NTFS file systems). I'm guessing that this is a bug that would be fixed in the future when OS X supports writing to NTFS volumes natively.

    So, if you want to share something on your Mac over the network, and you want to define users and their permissions, you should make sure that the folders that you're sharing are on a drive or partition formatted to HFS+.
  5. Matthew Yohe macrumors 68020

    Oct 12, 2006
    Ah nice, but don't expect OSX to support writing to NTFS in the future. The way that things like 3G-NTFS or whatever write to a NTFS volume is sort of hacky anyway. If you can, I would look into using exFAT now instead of NTFS (if that works for your environment).
  6. MacSignal macrumors regular

    May 8, 2010
    According to Wikipedia, Apple added exFat support to 10.6.5 in November.
  7. mrk2010 thread starter macrumors newbie

    Dec 27, 2010
    Terrific, I can reformat my storage partition as exFAT to have native read/write access in both OSs.

    Unfortunately, sharing a folder on an exFAT volume still does not make the settings stick. I can only assume at this point that OS X only saves user permissions for HFS+ file systems.

    Since I don't intend to share my files with anyone else, I've decided to enable Remote Login. By doing this, I would be able to see the entire hard drive on my MacBook Pro, but only after entering my username and password. A bit of an inconvenience to navigate through the folders, but it works.

Share This Page