File sharing wonky after Sno/Leopard + Migration Assistant...

Discussion in 'macOS' started by whyrichard, Oct 3, 2009.

  1. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #1
    Hello,


    I recently bought a new mac pro and it's fantastic... EXCEPT i can't get file sharing between my two macs to work correctly at all.

    Initially i used migration assistant between my two computers, and then upgraded both to snow leopard...

    Now when i try to fileshare through ethernet using the procedures that have worked for me in the past i cannot get file sharing to work consistently at all.

    Strange combination of issues:

    -When i try to copy or move files it often (maybe always?) asks for my password
    -when i try to copy a folder none or nearly none of its contents copy...
    -often there seem to be permissions issues (i did repair permissions on both computers)

    I initially came across this problem when trying to use chronosync --it doesn't work any longer needless to say...

    -Could it be that the permissions are all crazy because the user account transffered from my old mac and my new mac, with the same user name/password etc?


    Thank you very much for any advice, this is driving me nuts.


    r.
     
  2. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #2
    And when copying a file to the other computer it tells me that the file already exists (and in that location it does not) and when i click replace i get the message:

    The operation can't be completed because an item with the name "" already exists.

    ...though sometimes when it gives me the option to stop or replace. when i pick stop the file does indeed transfer...?!

    When i try it the other way around (From my macbook to my mac pro) it SOMETIMES seems to copy, but the file on the other end is 'empty'.


    hmmurghfs.

    r.




    IT SEEMS THAT the overriding behavior is:
    -i can copy from the other computer
    -i cannot copy to the other computer.
    this, regardless of which computer i am on.

    in otherwords when i am on my mac pro and i connect to the macbook, i can copy FROM but not TO the mac book. and when i am on the mac book and i connect to the mac pro, i can copy FROM but not TO the mac pro.

    any suggestions at all?


    I will no longer let this suck up my saturday!

    thanks,
    r.
     
  3. Bunsen macrumors member

    Joined:
    May 1, 2007
    Location:
    Orlando FL
    #3
    I've been having this same problem with SL. When file sharing between my two laptops, I can only copy from the remote machine, never push to it. (with the same errors you describe) I didn't use migration assistant, however, both machines do have the same short name and password. This seems to be the problem. I just confirmed that it still happens when I change the password on the remote machine, so it probably has to do with the fact that the short name on both computers is the same. I don't have the issue with another computer with a different account name.
    Not sure what's going on, I never had this problem with Leopard on the same machines. I guess I will have to make a new account on my backup computer.
     
  4. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #4
    Finally a response!

    Yeah, it was an issue for me for a month and a half until i finally bit the bullet and created a new user account on my new machine and moved things over.

    The question then was how do i change permissions of my files from one account to another. The only way I found was by going to my old user accounts main folder and change it's permissions to be:
    -read/write with my new account
    -and apply it to all subfolders

    I then logged in to my new account and went to that folder's info/permissions and set:
    -I am the owner (or something like that)

    I then could move files easily from my old account to my new one.
    A pain in the a.

    but it seemed to have worked.
    r.
     

Share This Page