File Sharing won't 'unshare'

Discussion in 'Mac Basics and Help' started by kevinsa, Aug 15, 2010.

  1. kevinsa macrumors newbie

    Joined:
    Nov 29, 2008
    #1
    I setup file sharing on my mac to access files over ftp or afp. However, after deleting these shares from my system preferences sharing panel, I can still access these shares if I connect.

    Please note that I am accessing the share from the computer itself. ie afp://192.168.1.65

    I'm not sure if this has any significance.

    System Preferences

    [​IMG]

    Accessing Shares

    [​IMG]

    Succesfully Connecting

    [​IMG]

    Does anybody know what's going on?

    Thanks in advance

    Kev
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Might be a Mac OS X bug. Could also be that File Sharing won't apply your changes to shared folders if doing so causes their number to drop to 0, which makes sense - why enable File Sharing in that case?
     
  3. kevinsa thread starter macrumors newbie

    Joined:
    Nov 29, 2008
    #3
    Well I was testing it out, and it is something I would like to use for just one folder, not all the ones you can see in the screenshot.

    I get the same problem whether the preferences bit is empty or has one share in it.

    EDIT

    Do you know the preference file associated with this which I could reset somehow?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Oh... it's because you're an administrator. Admins have access to all volumes on the computer. If you create another user account, just for sharing purposes, and do NOT give it administrator rights, then add a shared folder for that account - it'll work the way you want it to.
     
  5. kevinsa thread starter macrumors newbie

    Joined:
    Nov 29, 2008
    #5
    That has done it. Thanks.

    I didn't need to make a whole new user account, I just made a sharing account from within the sharing system preferences.
     

Share This Page