File Sharing won't work - Screen sharing does work (OS Lion)

Discussion in 'Mac OS X Lion (10.7)' started by bangdigital, Jul 21, 2011.

  1. bangdigital macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    I have a late 2008 iMac and a late 2009 MBP.

    I am a MobileMe member.

    Since upgrading to Lion Screen Sharing between them works normally, but I can't connect for file sharing between the two machines.

    Same result when both on the same WiFi network, and when on different WiFi networks.

    Anybody any thoughts on why this would happen? (And how I can fix it?)
     
  2. maviso5 macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #2
    I have the same thing, i Can screen share my Mac but not file share, tried connect as... and put in my credentials but "failed"

    Anyone else?
     
  3. Sykotic macrumors member

    Joined:
    Aug 25, 2009
    #3
    I'm having issues, too. I have a 2010 Mac Mini and did the Lion upgrade yesterday. Now neither of my WD TV Live boxes can see the Drobo shared through the Mac Mini anymore.

    My HTPC running Windows 7 isn't having any issues. But I can't even see the Drobo share through the virtual Windows 7 I'm running through VM Ware Fusion on the Mac Mini itself.
     
  4. GreyMatta macrumors regular

    Joined:
    Jul 29, 2007
    Location:
    England
    #4
    Count me in on this as well. I can log in as guest but thats it
     
  5. maviso5 macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #5
    hmm can't even seem to do either screenshare or file share now! can go in as guest and do a few bits....

    this is cr*p!
     
  6. bangdigital thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    Just to clarify my OP.

    I can see the machines in the Shared devices part of finder.

    And I can Screen share. Just can't actually access the folders. Just comes up as connection failed.

    Doesn't even work when I use my Mobile Me address - so essentially Back to my Mac doesn't work with Lion.
     
  7. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #7
    Screen sharing and file sharing works fine for me. And I've logged in thru SSH with no problem too.
     
  8. dsbnz macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    New Zealand
    #8
    Try switching off "Share files and folders using AFP" in System Preferences -> Sharing -> File Sharing -> Options.

    I had both AFP & SMB enabled and lost ability to connect to shares, except via guest access. After switching off AFP (leaving SMB enabled), problem seems to be gone. Bizarre !
     
  9. cjedj macrumors newbie

    Joined:
    Nov 2, 2009
    #9
    This worked for me as well. Weird, and not very reassuring.
     
  10. maviso5 macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #10
    That worked for me too!

    Also turning off remote management for me and just turning on screensharing got that back too.

    Bit odd but at least I can work again now.
     
  11. GreyMatta macrumors regular

    Joined:
    Jul 29, 2007
    Location:
    England
  12. Joe-Diver macrumors 6502

    Joe-Diver

    Joined:
    Aug 2, 2009
    #12
    Turning off AFP worked for me. I wasn't even using SMB before (it wasn't checked) so don't know what's up with AFP....but this fix worked and I'm back to sharing files.

    Thanks!!!!!!!
     
  13. bangdigital thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #13
    Thanks for the tip.

    Yes, turning off AFP allows me to fileshare again using a user account and MobileMe address.

    Many thanks.

    Let's hope Apple solve whatever the problem is with AFP in time for the next update.
     
  14. rog macrumors 6502

    Joined:
    Apr 9, 2003
    Location:
    Kalapana, HI
    #14
    Can't fileshare here either unless AFP off and SMB on. Totally unable to file share using MobileMe login. Paid membership with new airport extreme so Back to My Mac is supposed to work. MobileMe can't die a fast enough death as far as I'm concerned.
     
  15. rog macrumors 6502

    Joined:
    Apr 9, 2003
    Location:
    Kalapana, HI
    #15
    Filesharing works with AFP!

    had to remove any Home folder from being shared and now AFP works again. Screen sharing alone works too and don't have to have Remote Management on!
     
  16. bigchops macrumors newbie

    Joined:
    Jul 24, 2011
    #16
  17. mdynarski macrumors newbie

    Joined:
    Jul 29, 2011
    #17
    turning of AFP worked, unsharing home folder did not

    Turning off AFP worked; I was trying to transfer files between a MBP and a Mini. Needed to do it on both machines.

    This problem is really an odd one for a new operating system.

    Still haven't gotten Airdrop to see files. And the machines are on the same home wireless. Ah, the bleeding edge of a 1.0 OS.

    M
     
  18. robogobo macrumors 6502

    robogobo

    Joined:
    Jun 6, 2005
    Location:
    Sitting down facing front.
    #18
    That's the better solution. Worked for me too. Just remove your home directory from the list under Shared Folders in System Preferences>Sharing>File Sharing. No need to disable AFP.
     
  19. Joe-Diver macrumors 6502

    Joe-Diver

    Joined:
    Aug 2, 2009
    #19
    Did not work for me.

    I was able to connect my MBP when on my iMac, but was not able to connect my iMac when on my MBP. Tried resetting passwords, different accounts, etc. Nada.

    Went back to SMB and all works perfectly.
     
  20. nagromme, Oct 10, 2011
    Last edited: Oct 10, 2011

    nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #20
    Same problem here. I can’t share from Lion Air (10.7.1) to my Leopard Mac. I can Screen Share though.

    Turning AFP off and SMB on did not work. (In fact, Leopard won’t even TRY to connect then—it says Connection Failed and the option to Connect As is ghosted out. At least with AFP on I can Connect As, but is stays at Connecting... forever.)

    No home folders were in my Lion Shared Folders. (This was migrated from my old Snow Leopard Air.)

    Sneakernet time?

    EDIT: Here’s some craziness: it worked when I tried my long name (first and last) instead of my short account name! AFP on, SMB off.

    Weird, but I seem to be in business :)
     
  21. woodenbrain macrumors member

    Joined:
    Sep 2, 2009
    #21
    ditto, with the edit. trying to connect to a Lion mac (10.7.2) from a Mac running 10.6.8. On the Lion Mac I tried removing the home folders, and tried toggling AFP off & on, and made sure SMB was not also on (I'm aware of problems with SMB on Lion). I did not (for that reason) try SMB on and AFP off. Nothing worked. But using my long name did. Hopefully that will be fixed???
     
  22. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #22
    :confused:I have a related but slightly different issue with file sharing, running Sl on a MBP and Lion on a Mac mini base model. Same situation on both machines.
    The file sharing button in System Preferences/Sharing cannot be set - I can highlight it but it stays as is, with no check mark, no matter how many times you click on it.
    However, even in this state, I can access this SL system and the whole HD from the Mac mini, and vice versa, so obviously file sharing is on!
    When I enable SMB in the Options either, the File Sharing button gets a check mark enabled! Which is :cool: But this file sharing issue, not really a problem as file sharing does work even if the box is not checked, is rather inexplicable. Must be a bug in both SL and Lion :eek:
    And I don't see the Home folder included as a default in Lion as mentioned above, but rather the public folder (which is in the Home folder). So that solution doesn't work for me.
     
  23. Brentano macrumors newbie

    Joined:
    May 3, 2012
    #23
    I didn't have to turn off AFP

    Same problem here: Screen sharing was fine, but no volumes in file sharing and "Connect As..." didn't do anything.

    I have so many volumes attached and shared, and so many different user accounts, it was taking forever to try to get afp disabled everywhere.

    Instead, I tried Go:Connect to Server (⌘K) from the Finder and typed the machine's local ip under smb (smb://10.0.1.#) to get there and it worked.
     

Share This Page