"File System Check Exit Code 8" -- Disk wont repair

Discussion in 'OS X Yosemite (10.10)' started by Hrothgar, Nov 17, 2014.

  1. Hrothgar, Nov 17, 2014
    Last edited: Nov 17, 2014

    Hrothgar macrumors 6502

    Joined:
    Mar 11, 2009
    Location:
    New York
    #1
    I'm not sure where this question should be posted.

    I've got a 3 tb Western Digital My Book Studio external drive that I use for backups. I bought it in July.

    I've got a 2 tb partition that I use for Time Machine and a 1 tb partition that holds old photos/music files.

    Last night, I started getting errors on time machine backups. I tried ejecting the disc, and got an error that it could not unmount. I tried disc verify and disc repair, and got similar errors -- that the disc could not unmount.

    I turned everything off. This morning I plugged it in and ran disc verify -- I got an error code that the disc needs to be repaired. When I ran disc repair got an error code that the disc couldn't be repaired, and, in red, "File System Check Exit Code 8."

    Any ideas how to fix this? Any ideas what caused this? Is it likely a bad drive, something I did or a software issue?

    Thanks.
     
  2. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #2
    try DiskWarrior
     
  3. Hrothgar thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    Location:
    New York
    #3
    In the Apple support forum, I saw someone had a similar problem and was advised to do a command-s reboot and then run fsck-y.

    Anyone know about this? Apparently it will fix something on the disk -- but the original poster in that thread seemed to have a problem with his computers internal drive, not an external drive.
     
  4. Hrothgar thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    Location:
    New York
    #4
    I seemed to have fixed the problem by reformatting the problem partition.
     
  5. nrsmac macrumors newbie

    Joined:
    Mar 26, 2015
    #5
    Hard drive

    I had the same WD 2TB My Passport and the issue was I had a powered USB hub and it wasn't plugged into power. Fixed it for me anyways :/
     
  6. Tygernoot macrumors member

    Joined:
    Jul 3, 2003
    Location:
    Brussels
    #6
    I had a similar issue recently, and it's a bit worrying.

    Two WD HDs (one Mirror and one Elements) were suddenly corrupted. The disks could only be mounted in read-only mode, as Yosemite said they couldn't be repaired and had to be formatted.

    After trying a disk repair, I was only able to (un)mount the disks again by rebooting. They were sort of 'stuck' in repair mode in Disk Utility. It also took ages for them to appear after the reboot. I could hear the disk 'rattling' (being accessed) for half an hour or so. Once they appeared, the popup came back saying they needed to be formatted.

    I moved all the data and formatted them, but I had the same issue come back on the Mirror version! I had another popup that the disk was read-only and needed to be formatted. After a reboot it seemed to work again, but then TM wouldn't back up the Mirror version any more at random times. Only a reboot would help that (for a short while).

    There were some issues with data loss on WD drives in Mavericks if you had the WD software installed. I never had that installed myself though.

    So now I'm no longer using the WD Mirror. I used it as a precaution in raid1 to store all my photos, but if the drives keep getting corrupted and TM stops working as well, then it's not a safe option any more.

    I bought an external HD from another manufacturer and stopped using WDs drives with Yosemite.

    I reused the other (Elements) drive for a Windows PC now and that seems to be OK so far.

    I really don't know what happened, but it seems quite worrying that two drives were lost at the same time, and that apparently I'm not the only one. I thought it was a rare corruption due to a power surge (although I use a UPS) or perhaps an incorrect disconnect/shut down. But it might as well be Yosemite corrupting the drives... :(
     
  7. macprint macrumors newbie

    Joined:
    May 7, 2015
    Location:
    Chattanooga, Tn
    #7
    Having the EXACT same problem with my Seagate 3T Backup Plus drive. In the process of backing up to another drive now. Hopefully reformatting the old drive will restore function.:(
     
  8. MacSaves macrumors newbie

    Joined:
    Jul 3, 2010
    #8
    Curious...

    A lot of drives are damaged during brown out situations. This is where the power has dipped but not enough for a blackout. You see this from time to time when a light in a lamp might wink down and then wink back up. If you see this, then your data is at risk.

    Everyone tells you the risk of spikes and it is something you need to account for, but brownouts are more subversive and can cause you no end of headaches. I had one client who moved a brand new building on the 8th floor. All their computers were working perfectly except a bank of three that kept needing a complete cleaning every two weeks. They thought we weren't doing our jobs right even though all the rest of the computers had no issues. I explained that I thought the power subject to brownouts, but they didn't believe me. So, I brought my UPS with voltage regulation (VERY IMPORTANT) and connected it to the middle machine. We then cleaned up all three once again. Two weeks later the middle one was humming along just fine without a single error and the other two had crapped out again. After this demonstration, they went to the building manager to discuss the problem. They found out that the outside wall power outlet we had been using was connected to the same circuit as the elevators.

    Long story short ( I know, too late ), you never know when you have bad power. The best protection is to get a UPS with voltage regulation. Every manufacturer names it different, but as long as is supplies power from the battery if the power it low, then that's the one you want. It will also protect you from spikes and blackouts. In addition, if you ever have your equipment damaged and it was determined that the UPS didn't protect it like it was supposed to, there is around $25,000 to $50,000 worth or protection from the company that makes the unit, so you are basically buying insurance.

    I service Macs all over and if every person had a UPS with voltage regulation, my business would be cut in half. It's the best thing you can buy for your computer and data. You only need to connect your computer and external hard drives to the voltage regulation side (some outlets are blackout only, so pay attention). Monitors, printers, etc. don't need it. Just data sensitive equipment.

    Hope this helps.
     
  9. billybaroo617 macrumors newbie

    Joined:
    Aug 30, 2015
    #9
    I've experienced the same problems described here (exit code 8). After failing in Yosemite, the same WD drive works fine in OS 10.6.8. If you have access to an old mac, this may be a quicker way to get at your files than DiskWarrior, etc.
     
  10. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #10
    That is good information. IMO many people do not have a Mac available running an older OS. It would be interesting to know if 10.7 or 10.8 would work. The older OS would allow easier recovery of the data, which might take awhile to copy, then your left with the reformat, and finally restoring the data back to the drive. Then there is the loss in faith in the reliability of the drive. When might it happen again? Additionally Time Machine data may not work after the copy. If the copying breaks TM then your left with loss of all of your TM back up data.

    I have had good luck with using Disk Warrior to repair and create an optimized directory for Time Machine volumes. It is pricey, but it could save a lot of drama. I do not have any WD or Seagate drives, but I still get Time Machine fragmented directories that result in slower and slower times to prepare for back up. When that happens I use Disk Warrior to repair the directory, so far I have not had a back up fail yet. BTW, I'm not a big fan of TM, I use it, but I also do weekly clones of my boot drive.
     
  11. bonimac macrumors newbie

    Joined:
    Feb 4, 2010
    #11
    I was struggling with the same issue last weeks. Started with error messages related to Time Machine on an external 3TB drive. Thought the drive gave up but then, after trying out al tricks i knew inclusive diskwarrior, discovered the source of the error was on the internal RAID-0 drives of my Mac mini!

    What finally solved it was using fsck in Single-User Mode.
    See: http://www.howtogeek.com/236978/how-to-repair-disk-and-file-system-problems-on-your-mac/
     
  12. robertryda, Aug 6, 2017
    Last edited: Aug 6, 2017

    robertryda macrumors newbie

    robertryda

    Joined:
    Aug 6, 2017
    #12
    I have a 3tb WD HDD that I have had for around 3 years as a hdd to keep my entire library at - installs, games, movies, samples, books, music etc. Without a reason it became unmountable and was grayed out in Disk Utility. Running under 10.10.5 OSX the disk utility thing never helped.

    By using STELLAR PHOENIX mac software I was able to completely verify my entire 3TB hdd, save this session, and recover folders one by one to smaller hdds. It works just perfect HOWEVER JUST USE THE QUICK RECOVERY FUNCTION otherwise you wouldnt be able to recognize your file structure and everything will be scrambled.

    Everything is now back in place, it took me 4 days to do and now Im about to re-format that 3tb hdd and to put everything back. I dont think it went corrupted because its bad - its only a single HFS+J partition that goes to sleep whenever I dont use it. Any ideas? Thanks!

    P.S: Once i re-formatted the HDD it went back on as the live volume, I am now loading the files back. I think it will take another day to finish, or at least half the time
     
  13. kelvinboog macrumors newbie

    kelvinboog

    Joined:
    Jan 30, 2018
    Location:
    Alicante, España
    #13
    Thank you so much for a suggestion of STELLAR PHOENIX. It saved me 800GB of files!
     
  14. beccabird macrumors newbie

    Joined:
    Mar 31, 2018
    #14

    Thank you! It worked perfectly and I am so very grateful!
     

Share This Page