File transfers from iMac to Windows Share on another computer. Very slow!

JoshFink

macrumors regular
Original poster
Aug 3, 2007
114
1
Atlanta, GA
Hopefully someone has some ideas on how best to troubleshoot this.

I have an iMac and a Windows 2003 File Server.

The iMac sits on a gigabit switch with another computer, an XP machine and the 2003 File Server sits on another gigabit switch.

The problem I'm having is that transfers from the iMac to the 2003 File Server are very slow whereas from the XP machine on the same switch they are fast.

Any ideas on how to test this or how I might fix the problem?

The Network interface itself is set to:
1000baseT
full-duplex
MTU: standard (1500)

I've tried it with both full-duplex and full-duplex (flow control).

The directory I'm transfering is a 7.56gb directory and it's taking over an hour to transfer.

Thanks

Josh
 

raffinux

macrumors newbie
Jul 12, 2007
23
0
Hi,

I would personally start Ethereal on the server and on the client and take a sniff of the traffic (some minutes should be enough) in both cases: fast and slow one. Then I would compare the traces.

You can find many many thing such as missed ACK, retransmission, TCP windowing problem etc. Some of this problem can be due to configuration issues, some other to hardware problems such as bad cable, bad switch port etc.

Good luck!
 

JoshFink

macrumors regular
Original poster
Aug 3, 2007
114
1
Atlanta, GA
Hi,

I would personally start Ethereal on the server and on the client and take a sniff of the traffic (some minutes should be enough) in both cases: fast and slow one. Then I would compare the traces.

You can find many many thing such as missed ACK, retransmission, TCP windowing problem etc. Some of this problem can be due to configuration issues, some other to hardware problems such as bad cable, bad switch port etc.

Good luck!
I've never used Ethereal. How easy is it for a basic user with no real knowledge of packet sniffing?

Thanks

Josh
 

JoshFink

macrumors regular
Original poster
Aug 3, 2007
114
1
Atlanta, GA
While searching, I found this post. It seems to help

1. disabled IPv6 on Mac OS X (System Preferences->Network->Configure->Configure IPv6->Off)

2. uninstalled ipv6 on Windows XP via command line: netsh interface ipv6 uninstall
3. on MAC OS X, set ACK no delay by addingto you /etc/smb.conf file (sudo vi /etc/smb.conf):

socket options = TCP_NODELAY IPTOS_LOWDELAY file.

I found it here : http://echeng.com/journal/2006/09/13/mac-os-x-slow-network-performance-to-windows-xp/

Instead of the transfer taking over an hour, it took 18 minutes. Huge difference
 

Similar threads

  • jimmyjames35
2
Replies
2
Views
220
  • theladyhemlock
5
Replies
5
Views
465
Replies
12
Views
958
Replies
3
Views
636
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.